# CVE-2026-2614: Arbitrary File Read via Prompt Tag Source Validation Bypass in mlflow/mlflow

> Unauthenticated attackers can read arbitrary files from the MLflow server by bypassing source path validation in model version creation.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 28 Aug 2026
- **Also known as:** BIT-mlflow-2026-2614, GHSA-42h5-h8qh-vv9v, PYSEC-2026-2654

## What is CVE-2026-2614?

CVE-2026-2614 is a high-severity path traversal vulnerability in Lfprojects Mlflow, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in the `_create_model_version()` handler of `mlflow/server/handlers.py` in mlflow/mlflow versions 3.9.0 and earlier allows an unauthenticated remote attacker to read arbitrary files from the server's filesystem. The issue arises when a `CreateModelVersion` request includes the tag `mlflow.prompt.is_prompt`, which bypasses source path validation. This enables an attacker to store an arbitrary local filesystem path as the model version source. The `get_model_version_artifact_handler()` function later uses this source to serve files without verifying the model version's prompt status, leading to a complete confidentiality compromise. This issue is fixed in version 3.10.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-2614?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 3.10.0 |
| `mlflow` | PyPI | All versions | 3.10.0 |
| `mlflow` | PyPI | All versions | 3.10.0 |
| `mlflow` | PyPI | All versions | 3.10.0 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2026-2614?

Upgrade mlflow to 3.10.0 or later.

## Is CVE-2026-2614 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2614 exists.

Public exploit code:

- MLflow <= 3.9.0 - Arbitrary File Read (nuclei): http/cves/2026/CVE-2026-2614.yaml

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2614 and fix it if it is affected.

What it is: CVE-2026-2614 is a high-severity path traversal vulnerability in Lfprojects Mlflow, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2614 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 3.10.0
- mlflow (PyPI): affected all versions; fixed in 3.10.0
- mlflow (PyPI): affected all versions; fixed in 3.10.0
- mlflow (PyPI): affected all versions; fixed in 3.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2614/ (Markdown: https://insights.sbomify.com/CVE-2026-2614/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2614
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2614
- OSV: https://osv.dev/vulnerability/CVE-2026-2614

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2614/
Summaries are generated and may contain mistakes; the official description above is the record.
