# CVE-2026-26186: Fleet has a SQL injection via backtick escape in ORDER BY parameter

> Authenticated attackers can inject SQL via the order_key parameter to disclose database information or cause denial of service in Fleet.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-49xw-vfc4-7p43, GO-2026-4557

## What is CVE-2026-26186?

CVE-2026-26186 is a medium-severity SQL injection vulnerability in fleetdm fleet, published on 26 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Fleet is open source device management software. A SQL injection vulnerability in versions prior to 4.80.1 allowed authenticated users to inject arbitrary SQL expressions via the `order_key` query parameter. Due to unsafe use of `goqu.I()` when constructing the `ORDER BY` clause, specially crafted input could escape identifier quoting and be interpreted as executable SQL. An authenticated attacker with access to the affected endpoint could inject SQL expressions into the underlying MySQL query. Although the injection occurs in an `ORDER BY` context, it is sufficient to enable blind SQL injection techniques that can disclose database information through conditional expressions that affect result ordering. Crafted expressions may also cause excessive computation or query failures, potentially leading to degraded performance or denial of service. No direct evidence of reliable data modification or stacked query execution was demonstrated. Version 4.80.1 fixes the issue. If an immediate upgrade is not possible, users should restrict access to the affected endpoint to trusted roles only and ensure that any user-supplied sort or column parameters are strictly allow-listed at the application or proxy layer.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-26186?

3 open source packages ship an affected version, including github.com/fleetdm/fleet/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.80.1 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.80.1 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.80.1 |

Products: Fleetdm Fleet.

## How do I fix CVE-2026-26186?

Upgrade github.com/fleetdm/fleet/v4 to 4.80.1 or later.

## Is CVE-2026-26186 being exploited?

There is no known exploitation of CVE-2026-26186 in the wild and no public exploit code.

## Other vulnerabilities in fleetdm fleet

- [CVE-2020-26276](https://insights.sbomify.com/CVE-2020-26276/): SAML authentication vulnerability in Fleet (critical 10.0)
- [CVE-2026-103264](https://insights.sbomify.com/CVE-2026-103264/): Fleet before 4.87.0 Authentication Bypass via Device Identifiers (critical 9.3)
- [CVE-2026-23518](https://insights.sbomify.com/CVE-2026-23518/): Fleet has a JWT signature bypass vulnerability in Azure AD MDM enrollment (critical 9.3)
- [CVE-2026-26062](https://insights.sbomify.com/CVE-2026-26062/): Fleet server may terminate unexpectedly when handling certain gRPC requests (high 8.7)
- [CVE-2026-26061](https://insights.sbomify.com/CVE-2026-26061/): Fleet's unbounded request body read allows remote Denial of Service (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26186 and fix it if it is affected.

What it is: CVE-2026-26186 is a medium-severity SQL injection vulnerability in fleetdm fleet, published on 26 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26186 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.80.1
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.80.1
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.80.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26186/ (Markdown: https://insights.sbomify.com/CVE-2026-26186/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26186
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26186
- OSV: https://osv.dev/vulnerability/CVE-2026-26186

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26186/
Summaries are generated and may contain mistakes; the official description above is the record.
