{"answers":{"affected":"1 open source package ship an affected version, including aquasecurity/trivy-action. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-26189 in the wild and no public exploit code.","fix":"Upgrade aquasecurity/trivy-action to 0.34.0 or later.","what":"CVE-2026-26189 is a medium-severity command injection vulnerability in aquasecurity trivy-action, published on 19 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-26189 and fix it if it is affected.\n\nWhat it is: CVE-2026-26189 is a medium-severity command injection vulnerability in aquasecurity trivy-action, published on 19 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-26189 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aquasecurity/trivy-action (GitHub Actions): affected from 0.31.0; fixed in 0.34.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-26189/ (Markdown: https://insights.sbomify.com/CVE-2026-26189/index.md)","id":"CVE-2026-26189","markdown":"https://insights.sbomify.com/CVE-2026-26189/index.md","name":"CVE-2026-26189","record":{"aliases":["GHSA-9p44-j4g5-cfx5"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"GitHub Actions","requires_auth":"high_privilege","summary":"Attackers can execute arbitrary commands in GitHub Actions runners by injecting shell metacharacters into Trivy Action inputs.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"trivy_action","vendor":"aquasec"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Trivy Action runs Trivy as GitHub action to scan a Docker container image for vulnerabilities. A command injection vulnerability exists in `aquasecurity/trivy-action` versions 0.31.0 through 0.33.1 due to improper handling of action inputs when exporting environment variables. The action writes `export VAR=\u003cinput\u003e` lines to `trivy_envs.txt` based on user-supplied inputs and subsequently sources this file in `entrypoint.sh`. Because input values are written without appropriate shell escaping, attacker-controlled input containing shell metacharacters (e.g., `$(...)`, backticks, or other command substitution syntax) may be evaluated during the sourcing process. This can result in arbitrary command execution within the GitHub Actions runner context. Version 0.34.0 contains a patch for this issue. The vulnerability is exploitable when a consuming workflow passes attacker-controlled data into any action input that is written to `trivy_envs.txt`. Access to user input is required by the malicious actor. Workflows that do not pass attacker-controlled data into `trivy-action` inputs, workflows that upgrade to a patched version that properly escapes shell values or eliminates the `source ./trivy_envs.txt` pattern, and workflows where user input is not accessible are not affected.","ecosystems":["GitHub Actions"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Trivy Action has a script injection via sourced env file in composite action","id":"CVE-2026-26189","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"GitHub Actions","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":1,"n_references":3,"next":{"headline":"Milvus Allows Unauthenticated Access to Restful API on Metrics Port (9091) Leads to Critical System Compromise","id":"CVE-2026-26190"},"packages":[{"ecosystem":"GitHub Actions","fixed":["0.34.0"],"introduced":["0.31.0"],"last_affected":[],"package":"aquasecurity/trivy-action","purl":null,"source":"GHSA-9p44-j4g5-cfx5"}],"prev":{"headline":"Freeform Craft Plugin CP UI (builder/integrations) has Stored Cross-Site Scripting (XSS) issue","id":"CVE-2026-26188"},"products":["trivy-action"],"published":"2026-02-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-19","vendors":["aquasecurity"]},"summary":"Attackers can execute arbitrary commands in GitHub Actions runners by injecting shell metacharacters into Trivy Action inputs.","url":"https://insights.sbomify.com/CVE-2026-26189/"}