# CVE-2026-26191: Fleet vulnerable to OS command injection in software packages

> Attackers can execute arbitrary commands as root or SYSTEM on managed endpoints by uploading crafted software packages with malicious metadata.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 15 May 2026
- **Also known as:** GHSA-9vcr-g537-3w5v, GO-2026-5301

## What is CVE-2026-26191?

CVE-2026-26191 is a medium-severity command injection vulnerability in fleetdm fleet, published on 14 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Fleet is open source device management software. Prior to version 4.81.0, a vulnerability in Fleet's software installer pipeline could allow a crafted software package to execute arbitrary commands as root (macOS/Linux) or SYSTEM (Windows) on managed endpoints when an uninstall is triggered. When a software package (.pkg, .deb, .rpm, .exe, or .msi) is uploaded to Fleet, metadata is extracted from the package binary and used to generate uninstall scripts. In affected versions, this metadata is not properly sanitized before being included in the generated scripts. A specially crafted package containing malicious values in its metadata fields could result in unintended command execution when the uninstall script runs on managed endpoints. Version 4.81.0 contains a patch. If an immediate upgrade is not possible, administrators should avoid uploading software packages obtained from untrusted or unverified sources. Additionally, administrators can manually inspect and edit auto-generated uninstall scripts before deployment.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-26191?

3 open source packages ship an affected version, including github.com/fleetdm/fleet/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.81.1 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.81.1 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.81.1 |

Products: Fleetdm Fleet.

## How do I fix CVE-2026-26191?

Upgrade github.com/fleetdm/fleet/v4 to 4.81.1 or later.

## Is CVE-2026-26191 being exploited?

There is no known exploitation of CVE-2026-26191 in the wild and no public exploit code.

## Other vulnerabilities in fleetdm fleet

- [CVE-2020-26276](https://insights.sbomify.com/CVE-2020-26276/): SAML authentication vulnerability in Fleet (critical 10.0)
- [CVE-2026-103264](https://insights.sbomify.com/CVE-2026-103264/): Fleet before 4.87.0 Authentication Bypass via Device Identifiers (critical 9.3)
- [CVE-2026-23518](https://insights.sbomify.com/CVE-2026-23518/): Fleet has a JWT signature bypass vulnerability in Azure AD MDM enrollment (critical 9.3)
- [CVE-2026-26062](https://insights.sbomify.com/CVE-2026-26062/): Fleet server may terminate unexpectedly when handling certain gRPC requests (high 8.7)
- [CVE-2026-26061](https://insights.sbomify.com/CVE-2026-26061/): Fleet's unbounded request body read allows remote Denial of Service (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26191 and fix it if it is affected.

What it is: CVE-2026-26191 is a medium-severity command injection vulnerability in fleetdm fleet, published on 14 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-26191 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.81.1
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.81.1
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.81.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26191/ (Markdown: https://insights.sbomify.com/CVE-2026-26191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26191
- OSV: https://osv.dev/vulnerability/CVE-2026-26191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26191/
Summaries are generated and may contain mistakes; the official description above is the record.
