# CVE-2026-26192: Open WebUI vulnerable to Stored XSS via iFrame in citations model

> Attackers can inject malicious scripts into chat citations via modified document metadata, leading to stored XSS when previews are viewed.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 19 Feb 2026
- **Also known as:** GHSA-xc8p-9rr6-97r2, PYSEC-2026-2769

## What is CVE-2026-26192?

CVE-2026-26192 is a high-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 19 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to version 0.7.0, aanually modifying chat history allows setting the `html` property within document metadata. This causes the frontend to enter a code path that treats document contents as HTML, and render them in an iFrame when the citation is previewed. This allows stored XSS via a weaponized document payload in a chat. The payload also executes when the citation is viewed on a shared chat. Version 0.7.0 fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-26192?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.7.0 |
| `open-webui` | PyPI | All versions | 0.7.0 |
| `open-webui` | PyPI | All versions | 0.7.0 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-26192?

Upgrade open-webui to 0.7.0 or later.

## Is CVE-2026-26192 being exploited?

There is no known exploitation of CVE-2026-26192 in the wild and no public exploit code.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26192 and fix it if it is affected.

What it is: CVE-2026-26192 is a high-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 19 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-26192 in the wild and no public exploit code.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.7.0
- open-webui (PyPI): affected all versions; fixed in 0.7.0
- open-webui (PyPI): affected all versions; fixed in 0.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26192/ (Markdown: https://insights.sbomify.com/CVE-2026-26192/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26192
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26192
- OSV: https://osv.dev/vulnerability/CVE-2026-26192

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26192/
Summaries are generated and may contain mistakes; the official description above is the record.
