{"answers":{"affected":"3 open source packages ship an affected version, including github.com/open-policy-agent/opa-envoy-plugin.","exploited":"There is no known exploitation of CVE-2026-26205 in the wild and no public exploit code.","fix":"Upgrade github.com/open-policy-agent/opa-envoy-plugin to 1.13.2-envoy-2 or later.","what":"CVE-2026-26205 is a high-severity authentication bypass vulnerability in open-policy-agent opa-envoy-plugin, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-26205 and fix it if it is affected.\n\nWhat it is: CVE-2026-26205 is a high-severity authentication bypass vulnerability in open-policy-agent opa-envoy-plugin, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-26205 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/open-policy-agent/opa-envoy-plugin (Go): affected all versions; fixed in 1.13.2-envoy-2\n- github.com/open-policy-agent/opa-envoy-plugin (Go): affected all versions; fixed in 1.13.2-envoy-2\n- github.com/open-policy-agent/opa-envoy-plugin (Go): affected all versions; fixed in 1.13.2-envoy-2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-26205/ (Markdown: https://insights.sbomify.com/CVE-2026-26205/index.md)","id":"CVE-2026-26205","markdown":"https://insights.sbomify.com/CVE-2026-26205/index.md","name":"CVE-2026-26205","record":{"aliases":["GHSA-9f29-v6mm-pw6w","GO-2026-4506"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OPA Envoy plugin","requires_auth":"none","summary":"Attackers can bypass access controls by crafting requests with double slashes, causing authorization policies to evaluate a different path than the backend serves.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"opa-envoy-plugun is a plugin to enforce OPA policies with Envoy. Versions prior to 1.13.2-envoy-2 have a vulnerability in how the `input.parsed_path` field is constructed. HTTP request paths are treated as full URIs when parsed; interpreting leading path segments prefixed with double slashes (`//`) as authority components, and therefore dropping them from the parsed path. This creates a path interpretation mismatch between authorization policies and backend servers, enabling attackers to bypass access controls by crafting requests where the authorization filter evaluates a different path than the one ultimately served. Version 1.13.2-envoy-2 fixes the issue.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"opa-envoy-plugin has an Authorization Bypass via Double-Slash Path Misinterpretation in `input.parsed_path`","id":"CVE-2026-26205","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Wazuh: API brute-force protection bypass via race condition in login attempt tracking","id":"CVE-2026-26206"},"packages":[{"ecosystem":"Go","fixed":["1.13.2-envoy-2"],"introduced":["0"],"last_affected":[],"package":"github.com/open-policy-agent/opa-envoy-plugin","purl":null,"source":"GHSA-9f29-v6mm-pw6w"},{"ecosystem":"Go","fixed":["1.13.2-envoy-2"],"introduced":["0"],"last_affected":[],"package":"github.com/open-policy-agent/opa-envoy-plugin","purl":"pkg:golang/github.com/open-policy-agent/opa-envoy-plugin","source":"GHSA-9f29-v6mm-pw6w"},{"ecosystem":"Go","fixed":["1.13.2-envoy-2"],"introduced":["0"],"last_affected":[],"package":"github.com/open-policy-agent/opa-envoy-plugin","purl":"pkg:golang/github.com/open-policy-agent/opa-envoy-plugin","source":"GO-2026-4506"}],"prev":{"headline":"Wazuh: Heap-based NULL WRITE Buffer Underflow in GetAlertData","id":"CVE-2026-26204"},"products":["opa-envoy-plugin"],"published":"2026-02-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-19","vendors":["open-policy-agent"]},"summary":"Attackers can bypass access controls by crafting requests with double slashes, causing authorization policies to evaluate a different path than the backend serves.","url":"https://insights.sbomify.com/CVE-2026-26205/"}