# CVE-2026-26205: opa-envoy-plugin has an Authorization Bypass via Double-Slash Path Misinterpretation in `input.parsed_path`

> Attackers can bypass access controls by crafting requests with double slashes, causing authorization policies to evaluate a different path than the backend serves.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 19 Feb 2026
- **Also known as:** GHSA-9f29-v6mm-pw6w, GO-2026-4506

## What is CVE-2026-26205?

CVE-2026-26205 is a high-severity authentication bypass vulnerability in open-policy-agent opa-envoy-plugin, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

opa-envoy-plugun is a plugin to enforce OPA policies with Envoy. Versions prior to 1.13.2-envoy-2 have a vulnerability in how the `input.parsed_path` field is constructed. HTTP request paths are treated as full URIs when parsed; interpreting leading path segments prefixed with double slashes (`//`) as authority components, and therefore dropping them from the parsed path. This creates a path interpretation mismatch between authorization policies and backend servers, enabling attackers to bypass access controls by crafting requests where the authorization filter evaluates a different path than the one ultimately served. Version 1.13.2-envoy-2 fixes the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-26205?

3 open source packages ship an affected version, including github.com/open-policy-agent/opa-envoy-plugin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/open-policy-agent/opa-envoy-plugin` | Go | All versions | 1.13.2-envoy-2 |
| `github.com/open-policy-agent/opa-envoy-plugin` | Go | All versions | 1.13.2-envoy-2 |
| `github.com/open-policy-agent/opa-envoy-plugin` | Go | All versions | 1.13.2-envoy-2 |

## How do I fix CVE-2026-26205?

Upgrade github.com/open-policy-agent/opa-envoy-plugin to 1.13.2-envoy-2 or later.

## Is CVE-2026-26205 being exploited?

There is no known exploitation of CVE-2026-26205 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26205 and fix it if it is affected.

What it is: CVE-2026-26205 is a high-severity authentication bypass vulnerability in open-policy-agent opa-envoy-plugin, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26205 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/open-policy-agent/opa-envoy-plugin (Go): affected all versions; fixed in 1.13.2-envoy-2
- github.com/open-policy-agent/opa-envoy-plugin (Go): affected all versions; fixed in 1.13.2-envoy-2
- github.com/open-policy-agent/opa-envoy-plugin (Go): affected all versions; fixed in 1.13.2-envoy-2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26205/ (Markdown: https://insights.sbomify.com/CVE-2026-26205/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26205
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26205
- OSV: https://osv.dev/vulnerability/CVE-2026-26205

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26205/
Summaries are generated and may contain mistakes; the official description above is the record.
