CVE-2026-26207 DIscourse's discourse-policy plugin lacks post access check

Medium 5.4 Published Updated

Authenticated users can modify policies on hidden posts and enumerate policy attachments due to missing access checks in the Discourse policy plugin.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-26207?

CVE-2026-26207 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 26 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, `discourse-policy` plugin allows any authenticated user to interact with policies on posts they do not have permission to view. The `PolicyController` loads posts by ID without verifying the current user's access, enabling policy group members to accept/unaccept policies on posts in private categories or PMs they cannot see and any authenticated user to enumerate which post IDs have policies attached via differentiated error responses (information disclosure). The issue is patched in versions 2025.12.2, 2026.1.1, and 2026.2.0 by adding a `guardian.can_see?(@post)` check in the `set_post` before_action, ensuring post visibility is verified before any policy action is processed. As a workaround, disabling the discourse-policy plugin (`policy_enabled = false`) eliminates the vulnerability. There is no other workaround without upgrading.

Weakness: CWE-862

Which versions are affected by CVE-2026-26207?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2025.12.2, 2026.1.1

Products include Discourse Discourse.

How do I fix CVE-2026-26207?

Upgrade discourse to a fixed version for your release line: 2025.12.2 or 2026.1.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-26207 being exploited?

There is no known exploitation of CVE-2026-26207 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-26207, GHSA-jr4h-w6p5-w55r.

Is CVE-2026-26207 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free