# CVE-2026-26207: DIscourse's discourse-policy plugin lacks post access check

> Authenticated users can modify policies on hidden posts and enumerate policy attachments due to missing access checks in the Discourse policy plugin.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** BIT-discourse-2026-26207, GHSA-jr4h-w6p5-w55r

## What is CVE-2026-26207?

CVE-2026-26207 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 26 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, `discourse-policy` plugin allows any authenticated user to interact with policies on posts they do not have permission to view. The `PolicyController` loads posts by ID without verifying the current user's access, enabling policy group members to accept/unaccept policies on posts in private categories or PMs they cannot see and any authenticated user to enumerate which post IDs have policies attached via differentiated error responses (information disclosure). The issue is patched in versions 2025.12.2, 2026.1.1, and 2026.2.0 by adding a `guardian.can_see?(@post)` check in the `set_post` before_action, ensuring post visibility is verified before any policy action is processed. As a workaround, disabling the discourse-policy plugin (`policy_enabled = false`) eliminates the vulnerability. There is no other workaround without upgrading.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-26207?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2025.12.2, 2026.1.1 |

Products: Discourse Discourse.

## How do I fix CVE-2026-26207?

Upgrade discourse to a fixed version for your release line: 2025.12.2 or 2026.1.1.

## Is CVE-2026-26207 being exploited?

There is no known exploitation of CVE-2026-26207 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26207 and fix it if it is affected.

What it is: CVE-2026-26207 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 26 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26207 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2025.12.2, 2026.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26207/ (Markdown: https://insights.sbomify.com/CVE-2026-26207/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26207
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26207
- OSV: https://osv.dev/vulnerability/CVE-2026-26207

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26207/
Summaries are generated and may contain mistakes; the official description above is the record.
