# CVE-2026-26216: Crawl4AI < 0.8.0 Docker API Unauthenticated Remote Code Execution via Hooks Parameter

> Unauthenticated attackers can execute arbitrary Python code via the hooks parameter in the Docker API, leading to full server compromise.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-5882-5rx9-xgxp, PYSEC-2026-33

## What is CVE-2026-26216?

CVE-2026-26216 is a critical code injection vulnerability in unclecode Crawl4AI, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Crawl4AI versions prior to 0.8.0 contain a remote code execution vulnerability in the Docker API deployment. The /crawl endpoint accepts a hooks parameter containing Python code that is executed using exec(). The __import__ builtin was included in the allowed builtins, allowing unauthenticated remote attackers to import arbitrary modules and execute system commands. Successful exploitation allows full server compromise, including arbitrary command execution, file read and write access, sensitive data exfiltration, and lateral movement within internal networks.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-26216?

3 open source packages ship an affected version, including crawl4ai and Crawl4AI. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `crawl4ai` | PyPI | All versions | 0.8.0 |
| `crawl4ai` | PyPI | All versions | 0.8.0 |
| `Crawl4AI` | PyPI | All versions | 0.8.0 |

Products: Kidocode Crawl4ai.

## How do I fix CVE-2026-26216?

Upgrade crawl4ai to 0.8.0 or later.

## Is CVE-2026-26216 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26216 exists.

Public exploit code:

- https://github.com/joaovicdev/EXPLOIT-CVE-2026-26216 (github_poc): https://github.com/joaovicdev/EXPLOIT-CVE-2026-26216
- Crawl4AI < 0.8.0 - Unauthenticated Remote Code Execution via Hooks Parameter (nuclei): http/cves/2026/CVE-2026-26216.yaml

## Other vulnerabilities in unclecode Crawl4AI

- [CVE-2026-57572](https://insights.sbomify.com/CVE-2026-57572/): Crawl4AI: Unauthenticated RCE via Chromium launch-argument injection in browser_config.extra_args (critical 10.0)
- [CVE-2026-53753](https://insights.sbomify.com/CVE-2026-53753/): Crawl4AI: AST Sandbox Escape via gi_frame.f_back Chain - Pre-Auth RCE in Docker API (critical 9.8)
- [CVE-2026-57571](https://insights.sbomify.com/CVE-2026-57571/): Crawl4AI arbitrary file write via download filename path traversal (critical 9.6)
- [CVE-2026-56265](https://insights.sbomify.com/CVE-2026-56265/): Crawl4AI - Authentication Bypass via Hardcoded JWT Signing Key (critical 9.3)
- [CVE-2026-56261](https://insights.sbomify.com/CVE-2026-56261/): Crawl4AI - Server-Side Request Forgery via Webhook URLs (critical 9.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26216 and fix it if it is affected.

What it is: CVE-2026-26216 is a critical code injection vulnerability in unclecode Crawl4AI, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26216 exists.

Affected packages and fixed versions:
- crawl4ai (PyPI): affected all versions; fixed in 0.8.0
- crawl4ai (PyPI): affected all versions; fixed in 0.8.0
- Crawl4AI (PyPI): affected all versions; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26216/ (Markdown: https://insights.sbomify.com/CVE-2026-26216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26216
- OSV: https://osv.dev/vulnerability/CVE-2026-26216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26216/
Summaries are generated and may contain mistakes; the official description above is the record.
