# CVE-2026-26217: Crawl4AI < 0.8.0 Docker API Local File Inclusion via file URL Handling

> Unauthenticated attackers can read arbitrary server files via file:// URLs in Crawl4AI Docker API endpoints, exposing sensitive data.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-vx9w-5cx4-9796, PYSEC-2026-34

## What is CVE-2026-26217?

CVE-2026-26217 is a critical path traversal vulnerability in unclecode Crawl4AI, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Crawl4AI versions prior to 0.8.0 contain a local file inclusion vulnerability in the Docker API deployment. The /execute_js, /screenshot, /pdf, and /html endpoints accept file:// URLs, allowing unauthenticated remote attackers to read arbitrary files from the server filesystem. An attacker can access sensitive files such as /etc/passwd, /etc/shadow, application configuration files, and environment variables via /proc/self/environ, potentially exposing credentials, API keys, and internal application structure.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-26217?

3 open source packages ship an affected version, including crawl4ai and Crawl4AI. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `crawl4ai` | PyPI | All versions | 0.8.0 |
| `crawl4ai` | PyPI | All versions | 0.8.0 |
| `Crawl4AI` | PyPI | All versions | 0.8.0 |

Products: Kidocode Crawl4ai.

## How do I fix CVE-2026-26217?

Upgrade crawl4ai to 0.8.0 or later.

## Is CVE-2026-26217 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26217 exists.

Public exploit code:

- Crawl4AI < 0.8.0 - Local File Inclusion (nuclei): http/cves/2026/CVE-2026-26217.yaml

## Other vulnerabilities in unclecode Crawl4AI

- [CVE-2026-57572](https://insights.sbomify.com/CVE-2026-57572/): Crawl4AI: Unauthenticated RCE via Chromium launch-argument injection in browser_config.extra_args (critical 10.0)
- [CVE-2026-26216](https://insights.sbomify.com/CVE-2026-26216/): Crawl4AI < 0.8.0 Docker API Unauthenticated Remote Code Execution via Hooks Parameter (critical 10.0)
- [CVE-2026-53753](https://insights.sbomify.com/CVE-2026-53753/): Crawl4AI: AST Sandbox Escape via gi_frame.f_back Chain - Pre-Auth RCE in Docker API (critical 9.8)
- [CVE-2026-57571](https://insights.sbomify.com/CVE-2026-57571/): Crawl4AI arbitrary file write via download filename path traversal (critical 9.6)
- [CVE-2026-56265](https://insights.sbomify.com/CVE-2026-56265/): Crawl4AI - Authentication Bypass via Hardcoded JWT Signing Key (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26217 and fix it if it is affected.

What it is: CVE-2026-26217 is a critical path traversal vulnerability in unclecode Crawl4AI, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26217 exists.

Affected packages and fixed versions:
- crawl4ai (PyPI): affected all versions; fixed in 0.8.0
- crawl4ai (PyPI): affected all versions; fixed in 0.8.0
- Crawl4AI (PyPI): affected all versions; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26217/ (Markdown: https://insights.sbomify.com/CVE-2026-26217/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26217
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26217
- OSV: https://osv.dev/vulnerability/CVE-2026-26217

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26217/
Summaries are generated and may contain mistakes; the official description above is the record.
