# CVE-2026-26226: beautiful-mermaid < 0.1.3 SVG Attribute Injection

> Attackers can inject malicious SVG attributes via Mermaid diagrams, leading to cross-site scripting and script execution in the embedding origin.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Feb 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-cgmm-x5ww-q5cr

## What is CVE-2026-26226?

CVE-2026-26226 is a medium-severity cross-site scripting vulnerability in lukilabs beautiful-mermaid, published on 13 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

beautiful-mermaid versions prior to 0.1.3 contain an SVG attribute injection issue that can lead to cross-site scripting (XSS) when rendering attacker-controlled Mermaid diagrams. User-controlled values from Mermaid style and classDef directives are interpolated into SVG attribute values without proper escaping, allowing crafted input to break out of an attribute context and inject arbitrary SVG elements/attributes into the rendered output. When the generated SVG is embedded in a web page, this can result in script execution in the context of the embedding origin.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-26226?

2 open source packages ship an affected version, including beautiful-mermaid.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `beautiful-mermaid` | npm | All versions | 0.1.3 |
| `beautiful-mermaid` | npm | All versions | 0.1.3 |

## How do I fix CVE-2026-26226?

Upgrade beautiful-mermaid to 0.1.3 or later.

## Is CVE-2026-26226 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26226 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26226 and fix it if it is affected.

What it is: CVE-2026-26226 is a medium-severity cross-site scripting vulnerability in lukilabs beautiful-mermaid, published on 13 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26226 exists.

Affected packages and fixed versions:
- beautiful-mermaid (npm): affected all versions; fixed in 0.1.3
- beautiful-mermaid (npm): affected all versions; fixed in 0.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26226/ (Markdown: https://insights.sbomify.com/CVE-2026-26226/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26226
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26226
- OSV: https://osv.dev/vulnerability/CVE-2026-26226

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26226/
Summaries are generated and may contain mistakes; the official description above is the record.
