# CVE-2026-26232: Gitea OAuth2 authorization codes lack expiry and reuse enforcement

> Attackers can reuse expired OAuth2 authorization codes to bypass authentication and potentially take over user accounts in Gitea.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2026
- **Updated:** 7 Jul 2026
- **Also known as:** GHSA-5v69-g2m3-3hq3, GO-2026-6336

## What is CVE-2026-26232?

CVE-2026-26232 is a critical authentication bypass vulnerability in Gitea Open Source Git Server, published on 3 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gitea versions before 1.25.5 do not consistently enforce OAuth2 authorization code expiry and single-use behavior during token exchange.

Weakness: CWE-294 (Authentication Bypass by Capture-replay)

## Which versions are affected by CVE-2026-26232?

3 open source packages ship an affected version, including code.gitea.io/gitea.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.gitea.io/gitea` | Go | All versions | 1.25.5 |
| `code.gitea.io/gitea` | Go | All versions | 1.25.5 |
| `code.gitea.io/gitea` | Go | All versions | 1.25.5 |

## How do I fix CVE-2026-26232?

Upgrade code.gitea.io/gitea to 1.25.5 or later.

## Is CVE-2026-26232 being exploited?

There is no known exploitation of CVE-2026-26232 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26232 and fix it if it is affected.

What it is: CVE-2026-26232 is a critical authentication bypass vulnerability in Gitea Open Source Git Server, published on 3 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26232 in the wild and no public exploit code.

Affected packages and fixed versions:
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.25.5
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.25.5
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.25.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26232/ (Markdown: https://insights.sbomify.com/CVE-2026-26232/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26232
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26232
- OSV: https://osv.dev/vulnerability/CVE-2026-26232

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26232/
Summaries are generated and may contain mistakes; the official description above is the record.
