CVE-2026-26233 Denial of Service via HTTP/2 single packet attack on login endpoint
Unauthenticated attackers can crash the Mattermost server by sending parallel HTTP/2 login requests due to missing rate limiting.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-26233?
CVE-2026-26233 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to rate limit login requests which allows unauthenticated remote attackers to cause denial of service (server crash and restart) via HTTP/2 single packet attack with 100+ parallel login requests.. Mattermost Advisory ID: MMSA-2025-00566
Weakness: CWE-400
Which versions are affected by CVE-2026-26233?
9 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1 | 10.11.12 |
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1 | 10.11.12 |
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1+incompatible | 10.11.12+incompatible, 11.2.4+incompatible, 11.3.2+incompatible, 11.4.1+incompatible |
github.com/mattermost/mattermost-server Go | From 11.2.0-rc1 | 11.2.4 |
github.com/mattermost/mattermost-server Go | From 11.2.0-rc1 | 11.2.4 |
github.com/mattermost/mattermost-server Go | From 11.3.0-rc1 | 11.3.2 |
3 more packages
github.com/mattermost/mattermost-server Go | From 11.3.0-rc1 | 11.3.2 |
github.com/mattermost/mattermost-server Go | From 11.4.0-rc1 | 11.4.1 |
github.com/mattermost/mattermost-server Go | From 11.4.0-rc1 | 11.4.1 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-26233?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.12, 10.11.12+incompatible, 11.2.4+incompatible or 11.3.2+incompatible.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-26233 being exploited?
There is no known exploitation of CVE-2026-26233 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-247x-7qw8-fp98, GO-2026-4916.