# CVE-2026-26247: Gitea OAuth2 PKCE S256 challenges are not enforced during token exchange

> Attackers can bypass OAuth2 PKCE verification to obtain tokens without the correct verifier, potentially leading to unauthorized access.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2026
- **Updated:** 7 Jul 2026
- **Also known as:** GHSA-m5ch-ppfx-xv3v, GO-2026-6342

## What is CVE-2026-26247?

CVE-2026-26247 is a critical authentication bypass vulnerability in Gitea Open Source Git Server, published on 3 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gitea versions before 1.25.5 do not persist the OAuth2 PKCE S256 challenge method correctly during authorization, allowing token exchange without the expected verifier check.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-26247?

3 open source packages ship an affected version, including code.gitea.io/gitea.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.gitea.io/gitea` | Go | All versions | 1.25.5 |
| `code.gitea.io/gitea` | Go | All versions | 1.25.5 |
| `code.gitea.io/gitea` | Go | All versions | 1.25.5 |

## How do I fix CVE-2026-26247?

Upgrade code.gitea.io/gitea to 1.25.5 or later.

## Is CVE-2026-26247 being exploited?

There is no known exploitation of CVE-2026-26247 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26247 and fix it if it is affected.

What it is: CVE-2026-26247 is a critical authentication bypass vulnerability in Gitea Open Source Git Server, published on 3 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26247 in the wild and no public exploit code.

Affected packages and fixed versions:
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.25.5
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.25.5
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.25.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26247/ (Markdown: https://insights.sbomify.com/CVE-2026-26247/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26247
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26247
- OSV: https://osv.dev/vulnerability/CVE-2026-26247

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26247/
Summaries are generated and may contain mistakes; the official description above is the record.
