# CVE-2026-26274: October: Safe Mode Bypass via Twig Database Write Operations

> Backend users with Developer permissions can bypass Safe Mode to modify database tables via Twig templates in October CMS.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 21 Apr 2026
- **Also known as:** GHSA-h6jm-f4hh-fw27

## What is CVE-2026-26274?

CVE-2026-26274 is a medium-severity vulnerability in octobercms october, published on 21 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

October is a Content Management System (CMS) and web platform. Prior to 3.7.14 and 4.1.10, a vulnerability was identified in the Twig sandbox security policy that allowed database write operations when cms.safe_mode is enabled. Backend users with Developer permissions could use Twig template markup to execute insert, update, and delete operations on any database table through the query builder, which is included in the sandbox allow-list. This vulnerability is fixed in 3.7.14 and 4.1.10.

Weakness: CWE-863 (Incorrect Authorization), CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-26274?

4 open source packages ship an affected version, including october/october.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `october/october` | Packagist | All versions | 3.7.14 |
| `october/october` | Packagist | All versions | 3.7.14 |
| `october/october` | Packagist | From 4.0.0 | 4.1.10 |
| `october/october` | Packagist | From 4.0.0 | 4.1.10 |

## How do I fix CVE-2026-26274?

Upgrade october/october to a fixed version for your release line: 3.7.14 or 4.1.10.

## Is CVE-2026-26274 being exploited?

There is no known exploitation of CVE-2026-26274 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26274 and fix it if it is affected.

What it is: CVE-2026-26274 is a medium-severity vulnerability in octobercms october, published on 21 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26274 in the wild and no public exploit code.

Affected packages and fixed versions:
- october/october (Packagist): affected all versions; fixed in 3.7.14
- october/october (Packagist): affected all versions; fixed in 3.7.14
- october/october (Packagist): affected from 4.0.0; fixed in 4.1.10
- october/october (Packagist): affected from 4.0.0; fixed in 4.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26274/ (Markdown: https://insights.sbomify.com/CVE-2026-26274/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26274
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26274
- OSV: https://osv.dev/vulnerability/CVE-2026-26274

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26274/
Summaries are generated and may contain mistakes; the official description above is the record.
