# CVE-2026-26275: httpsig-hyper has Improper Digest Verification that May Allow Message Integrity Bypass

> Attackers can bypass HTTP message integrity checks due to flawed digest verification logic in the httpsig-hyper library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** GHSA-7v42-g35v-xrch

## What is CVE-2026-26275?

CVE-2026-26275 is a high-severity vulnerability in junkurihara httpsig-rs, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

httpsig-hyper is a hyper extension for http message signatures. An issue was discovered in `httpsig-hyper` prior to version 0.0.23 where Digest header verification could incorrectly succeed due to misuse of Rust's `matches!` macro. Specifically, the comparison `if matches!(digest, _expected_digest)` treated `_expected_digest` as a pattern binding rather than a value comparison, resulting in unconditional success of the match expression. As a consequence, digest verification could incorrectly return success even when the computed digest did not match the expected value. Applications relying on Digest verification as part of HTTP message signature validation may therefore fail to detect message body modification. The severity depends on how the library is integrated and whether additional signature validation layers are enforced. This issue has been fixed in `httpsig-hyper` 0.0.23. The fix replaces the incorrect `matches!` usage with proper value comparison and additionally introduces constant-time comparison for digest verification as defense-in-depth. Regression tests have also been added to prevent reintroduction of this issue. Users are strongly advised to upgrade to the patched version. There is no reliable workaround without upgrading. Users who cannot immediately upgrade should avoid relying solely on Digest verification for message integrity and ensure that full HTTP message signature verification is enforced at the application layer.

Weakness: CWE-697 (Incorrect Comparison), CWE-354 (Improper Validation of Integrity Check Value)

## Which versions are affected by CVE-2026-26275?

2 open source packages ship an affected version, including httpsig-hyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `httpsig-hyper` | crates.io | All versions | 0.0.23 |
| `httpsig-hyper` | crates.io | All versions | 0.0.23 |

Products: Junkurihara Httpsig-Hyper.

## How do I fix CVE-2026-26275?

Upgrade httpsig-hyper to 0.0.23 or later.

## Is CVE-2026-26275 being exploited?

There is no known exploitation of CVE-2026-26275 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26275 and fix it if it is affected.

What it is: CVE-2026-26275 is a high-severity vulnerability in junkurihara httpsig-rs, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26275 in the wild and no public exploit code.

Affected packages and fixed versions:
- httpsig-hyper (crates.io): affected all versions; fixed in 0.0.23
- httpsig-hyper (crates.io): affected all versions; fixed in 0.0.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26275/ (Markdown: https://insights.sbomify.com/CVE-2026-26275/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26275
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26275
- OSV: https://osv.dev/vulnerability/CVE-2026-26275

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26275/
Summaries are generated and may contain mistakes; the official description above is the record.
