# CVE-2026-26278: fast-xml-parser affected by DoS through entity expansion in DOCTYPE (no expansion limit)

> An attacker can cause denial of service in applications using fast-xml-parser by submitting XML with unlimited entity expansion, freezing the application.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 10 Sep 2026
- **Also known as:** CLEANSTART-2026-DE27040, CLEANSTART-2026-FQ78730, DEBIAN-CVE-2026-26278, ECHO-058b-a6ce-5049, GHSA-jmr7-xgp7-cmfj, MINI-474x-5c6m-9w4f, MINI-5q6f-qwp7-jj42, MINI-694q-5cxw-h794, MINI-6c6f-4vqf-pjx5, MINI-7gh2-64q4-vfr9, MINI-7w7p-pjjr-jvq8, MINI-85pm-888r-mvcw, MINI-gqpr-mm95-95c3, MINI-gx9x-vrcj-cp6r, MINI-mr55-5j4f-3x2p, MINI-v59w-g7w6-28cg, MINI-vv2w-87cp-6vgj, MINI-x3gc-7w7m-rqqg, MINI-x8cq-4wjc-h6r8, ROOT-APP-NPM-CVE-2026-26278, UBUNTU-CVE-2026-26278

## What is CVE-2026-26278?

CVE-2026-26278 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-xml-parser allows users to validate XML, parse XML to JS object, or build XML from JS object without C/C++ based libraries and no callback. In versions 4.1.3 through 5.3.5, the XML parser can be forced to do an unlimited amount of entity expansion. With a very small XML input, it’s possible to make the parser spend seconds or even minutes processing a single request, effectively freezing the application. Version 5.3.6 fixes the issue. As a workaround, avoid using DOCTYPE parsing by `processEntities: false` option.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2026-26278?

4 open source packages ship an affected version, including fast-xml-parser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-xml-parser` | npm | From 4.1.3 | 4.5.4 |
| `fast-xml-parser` | npm | From 4.1.3 | 4.5.4 |
| `fast-xml-parser` | npm | From 5.0.0 | 5.3.6 |
| `fast-xml-parser` | npm | From 5.0.0 | 5.3.6 |

Products: Naturalintelligence Fast-Xml-Parser.

## How do I fix CVE-2026-26278?

Upgrade fast-xml-parser to a fixed version for your release line: 4.5.4 or 5.3.6.

## Is CVE-2026-26278 being exploited?

There is no known exploitation of CVE-2026-26278 in the wild and no public exploit code.

## Other vulnerabilities in NaturalIntelligence fast-xml-parser

- [CVE-2026-25896](https://insights.sbomify.com/CVE-2026-25896/): fast-xml-parser has an entity encoding bypass via regex injection in DOCTYPE entity names (critical 9.3)
- [CVE-2026-33036](https://insights.sbomify.com/CVE-2026-33036/): fast-xml-parser affected by numeric entity expansion bypassing all entity expansion limits (incomplete fix for CVE-2026-26278) (high 7.5)
- [CVE-2026-25128](https://insights.sbomify.com/CVE-2026-25128/): fast-xml-parser has RangeError DoS Numeric Entities Bug (high 7.5)
- [CVE-2024-41818](https://insights.sbomify.com/CVE-2024-41818/): ReDOS at currency parsing fast-xml-parser (high 7.5)
- [CVE-2023-34104](https://insights.sbomify.com/CVE-2023-34104/): Regex Injection via Doctype Entities (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26278 and fix it if it is affected.

What it is: CVE-2026-26278 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26278 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-xml-parser (npm): affected from 4.1.3; fixed in 4.5.4
- fast-xml-parser (npm): affected from 4.1.3; fixed in 4.5.4
- fast-xml-parser (npm): affected from 5.0.0; fixed in 5.3.6
- fast-xml-parser (npm): affected from 5.0.0; fixed in 5.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26278/ (Markdown: https://insights.sbomify.com/CVE-2026-26278/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26278
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26278
- OSV: https://osv.dev/vulnerability/CVE-2026-26278

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26278/
Summaries are generated and may contain mistakes; the official description above is the record.
