# CVE-2026-26280: Systeminformation has a Command Injection via unsanitized interface parameter in wifi.js retry path

> Attackers can execute arbitrary OS commands via unsanitized interface parameters in the wifiNetworks function of the systeminformation library.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLEANSTART-2026-FG19009, CLSA-2026-1790004555, DEBIAN-CVE-2026-26280, ECHO-4b25-5703-ecdd, GHSA-9c88-49p5-5ggf, MINI-9g4j-4x99-8r2j, MINI-hh22-8x45-w9h7, MINI-p8h9-mp23-fh86, MINI-q4mp-rph9-9324, MINI-qpp5-29jf-qhwh, MINI-qv5m-46g2-3r2c, MINI-qwrg-gxmr-pvm7, MINI-rmrm-mvgx-xc33, MINI-x6j8-p3fm-gxc4, ROOT-APP-NPM-CVE-2026-26280, UBUNTU-CVE-2026-26280

## What is CVE-2026-26280?

CVE-2026-26280 is a high-severity command injection vulnerability in sebhildebrandt systeminformation, published on 19 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

systeminformation is a System and OS information library for node.js. In versions prior to 5.30.8, a command injection vulnerability in the `wifiNetworks()` function allows an attacker to execute arbitrary OS commands via an unsanitized network interface parameter in the retry code path. In `lib/wifi.js`, the `wifiNetworks()` function sanitizes the `iface` parameter on the initial call (line 437). However, when the initial scan returns empty results, a `setTimeout` retry (lines 440-441) calls `getWifiNetworkListIw(iface)` with the **original unsanitized** `iface` value, which is passed directly to `execSync('iwlist ${iface} scan')`. Any application passing user-controlled input to `si.wifiNetworks()` is vulnerable to arbitrary command execution with the privileges of the Node.js process. Version 5.30.8 fixes the issue.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-26280?

2 open source packages ship an affected version, including systeminformation. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `systeminformation` | npm | All versions | 5.30.8 |
| `systeminformation` | npm | All versions | 5.30.8 |

Products: Systeminformation Systeminformation.

## How do I fix CVE-2026-26280?

Upgrade systeminformation to 5.30.8 or later.

## Is CVE-2026-26280 being exploited?

There is no known exploitation of CVE-2026-26280 in the wild and no public exploit code.

## Other vulnerabilities in sebhildebrandt systeminformation

- [CVE-2023-42810](https://insights.sbomify.com/CVE-2023-42810/): systeminformation SSID Command Injection Vulnerability (critical 9.8)
- [CVE-2021-21388](https://insights.sbomify.com/CVE-2021-21388/): Command Injection Vulnerability in systeminformation (high 8.9)
- [CVE-2026-26318](https://insights.sbomify.com/CVE-2026-26318/): systeminformation has Command Injection via Unsanitized `locate` Output in `versions()` (high 8.8)
- [CVE-2020-7752](https://insights.sbomify.com/CVE-2020-7752/): Command Injection (high 8.8)
- [CVE-2026-50289](https://insights.sbomify.com/CVE-2026-50289/): systeminformation: OS command injection in networkInterfaces() via interfaces(5) source-directive path on Linux (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26280 and fix it if it is affected.

What it is: CVE-2026-26280 is a high-severity command injection vulnerability in sebhildebrandt systeminformation, published on 19 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26280 in the wild and no public exploit code.

Affected packages and fixed versions:
- systeminformation (npm): affected all versions; fixed in 5.30.8
- systeminformation (npm): affected all versions; fixed in 5.30.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26280/ (Markdown: https://insights.sbomify.com/CVE-2026-26280/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26280
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26280
- OSV: https://osv.dev/vulnerability/CVE-2026-26280

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26280/
Summaries are generated and may contain mistakes; the official description above is the record.
