# CVE-2026-26304: Permission Bypass in Playbook Run Creation

> Team members can create unauthorized playbook runs by bypassing permission checks when the playbook ID is empty.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2026
- **Updated:** 17 Mar 2026
- **Also known as:** GHSA-4pmx-622h-x359, GO-2026-4812

## What is CVE-2026-26304?

CVE-2026-26304 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 11.3.x <= 11.3.0, 11.2.x <= 11.2.2 fail to verify run_create permission for empty playbookId, which allows team members to create unauthorized runs via the playbook run API. Mattermost Advisory ID: MMSA-2025-00542

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-26304?

3 open source packages ship an affected version, including github.com/mattermost/mattermost-plugin-playbooks. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-plugin-playbooks` | Go | All versions | 1.41.1-0.20260316224925-705f54a81841 |
| `github.com/mattermost/mattermost-plugin-playbooks` | Go | All versions | 1.41.1-0.20260316224925-705f54a81841 |
| `github.com/mattermost/mattermost-plugin-playbooks` | Go | All versions | 1.41.1-0.20260316224925-705f54a81841 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2026-26304?

Upgrade github.com/mattermost/mattermost-plugin-playbooks to 1.41.1-0.20260316224925-705f54a81841 or later.

## Is CVE-2026-26304 being exploited?

There is no known exploitation of CVE-2026-26304 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26304 and fix it if it is affected.

What it is: CVE-2026-26304 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26304 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-plugin-playbooks (Go): affected all versions; fixed in 1.41.1-0.20260316224925-705f54a81841
- github.com/mattermost/mattermost-plugin-playbooks (Go): affected all versions; fixed in 1.41.1-0.20260316224925-705f54a81841
- github.com/mattermost/mattermost-plugin-playbooks (Go): affected all versions; fixed in 1.41.1-0.20260316224925-705f54a81841

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26304/ (Markdown: https://insights.sbomify.com/CVE-2026-26304/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26304
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26304
- OSV: https://osv.dev/vulnerability/CVE-2026-26304

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26304/
Summaries are generated and may contain mistakes; the official description above is the record.
