CVE-2026-26308 Envoy has an RBAC Header Validation Bypass via Multi-Value Header Concatenation
Attackers can bypass Envoy RBAC deny rules by sending duplicate headers, allowing unauthorized access to protected resources.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-26308?
CVE-2026-26308 is a high-severity authentication bypass vulnerability in Envoyproxy Envoy, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Envoy is a high-performance edge/middle/service proxy. Prior to 1.37.1, 1.36.5, 1.35.8, and 1.34.13, the Envoy RBAC (Role-Based Access Control) filter contains a logic vulnerability in how it validates HTTP headers when multiple values are present for the same header name. Instead of validating each header value individually, Envoy concatenates all values into a single comma-separated string. This behavior allows attackers to bypass RBAC policies—specifically "Deny" rules—by sending duplicate headers, effectively obscuring the malicious value from exact-match mechanisms. This vulnerability is fixed in 1.37.1, 1.36.5, 1.35.8, and 1.34.13.
Weakness: CWE-863
Which versions are affected by CVE-2026-26308?
9 open source packages ship an affected version, including github.com/envoyproxy/envoy and envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/envoyproxy/envoy Go | All versions | 1.34.13 |
github.com/envoyproxy/envoy Go | All versions | 1.34.13 |
github.com/envoyproxy/envoy Go | From 1.35.0 | 1.35.9 |
github.com/envoyproxy/envoy Go | From 1.35.0 | 1.35.9 |
github.com/envoyproxy/envoy Go | From 1.36.0 | 1.36.5 |
github.com/envoyproxy/envoy Go | From 1.36.0 | 1.36.5 |
3 more packages
github.com/envoyproxy/envoy Go | From 1.37.0 | 1.37.1 |
github.com/envoyproxy/envoy Go | From 1.37.0 | 1.37.1 |
envoy Bitnami | All versions | 1.34.13, 1.35.9, 1.36.5, 1.37.1 |
Products include Envoyproxy Envoy.
How do I fix CVE-2026-26308?
Upgrade github.com/envoyproxy/envoy to a fixed version for your release line: 1.34.13, 1.35.9, 1.36.5 or 1.37.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-26308 being exploited?
There is no known exploitation of CVE-2026-26308 in the wild and no public exploit code.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2026-26308, GHSA-ghc4-35x6-crw5.