CVE-2026-26309 Envoy has an off-by-one write in JsonEscaper::escapeString()
An off-by-one write in Envoy's JSON escaper can corrupt string termination, leading to crashes or out-of-bounds reads.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-26309?
CVE-2026-26309 is a medium-severity memory corruption vulnerability in Envoyproxy Envoy, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Envoy is a high-performance edge/middle/service proxy. Prior to 1.37.1, 1.36.5, 1.35.8, and 1.34.13, an off-by-one write in Envoy::JsonEscaper::escapeString() can corrupt std::string null-termination, causing undefined behavior and potentially leading to crashes or out-of-bounds reads when the resulting string is later treated as a C-string. This vulnerability is fixed in 1.37.1, 1.36.5, 1.35.8, and 1.34.13.
Weakness: CWE-193
Which versions are affected by CVE-2026-26309?
9 open source packages ship an affected version, including github.com/envoyproxy/envoy and envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/envoyproxy/envoy Go | All versions | None |
github.com/envoyproxy/envoy Go | All versions | None |
github.com/envoyproxy/envoy Go | All versions to 1.34.12 | None |
github.com/envoyproxy/envoy Go | All versions to 1.34.12 | None |
github.com/envoyproxy/envoy Go | From 1.35.0 to 1.35.8 | None |
github.com/envoyproxy/envoy Go | From 1.35.0 to 1.35.8 | None |
3 more packages
github.com/envoyproxy/envoy Go | From 1.36.0 to 1.36.4 | None |
github.com/envoyproxy/envoy Go | From 1.36.0 to 1.36.4 | None |
envoy Bitnami | All versions | 1.34.13, 1.35.9, 1.36.5, 1.37.1 |
Products include Envoyproxy Envoy.
How do I fix CVE-2026-26309?
Upgrade to a fixed version.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-26309 being exploited?
There is no known exploitation of CVE-2026-26309 in the wild and no public exploit code.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2026-26309, GHSA-56cj-wgg3-x943.