# CVE-2026-26310: Crash for scoped ip address in Envoy during DNS

> Attackers can crash the Envoy proxy by sending scoped IPv6 addresses during DNS resolution, causing a denial of service.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 10 Mar 2026
- **Also known as:** BIT-envoy-2026-26310, GHSA-3cw6-2j68-868p

## What is CVE-2026-26310?

CVE-2026-26310 is a medium-severity denial of service vulnerability in Envoyproxy Envoy, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy is a high-performance edge/middle/service proxy. Prior to 1.37.1, 1.36.5, 1.35.8, and 1.34.13, calling Utility::getAddressWithPort with a scoped IPv6 addresses causes a crash. This utility is called in the data plane from the original_src filter and the dns filter. This vulnerability is fixed in 1.37.1, 1.36.5, 1.35.8, and 1.34.13.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-26310?

9 open source packages ship an affected version, including github.com/envoyproxy/envoy and envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/envoyproxy/envoy` | Go | All versions | None |
| `github.com/envoyproxy/envoy` | Go | All versions | None |
| `github.com/envoyproxy/envoy` | Go | All versions to 1.34.12 | None |
| `github.com/envoyproxy/envoy` | Go | All versions to 1.34.12 | None |
| `github.com/envoyproxy/envoy` | Go | From 1.35.0 to 1.35.8 | None |
| `github.com/envoyproxy/envoy` | Go | From 1.35.0 to 1.35.8 | None |
| `github.com/envoyproxy/envoy` | Go | From 1.36.0 to 1.36.4 | None |
| `github.com/envoyproxy/envoy` | Go | From 1.36.0 to 1.36.4 | None |
| `envoy` | Bitnami | All versions | 1.34.13, 1.35.9, 1.36.5, 1.37.1 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2026-26310?

Upgrade to a fixed version.

## Is CVE-2026-26310 being exploited?

There is no known exploitation of CVE-2026-26310 in the wild and no public exploit code.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26310 and fix it if it is affected.

What it is: CVE-2026-26310 is a medium-severity denial of service vulnerability in Envoyproxy Envoy, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26310 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/envoyproxy/envoy (Go): affected all versions; no fix listed
- github.com/envoyproxy/envoy (Go): affected all versions; no fix listed
- github.com/envoyproxy/envoy (Go): affected all versions up to 1.34.12; no fix listed
- github.com/envoyproxy/envoy (Go): affected all versions up to 1.34.12; no fix listed
- github.com/envoyproxy/envoy (Go): affected from 1.35.0 up to 1.35.8; no fix listed
- github.com/envoyproxy/envoy (Go): affected from 1.35.0 up to 1.35.8; no fix listed
- github.com/envoyproxy/envoy (Go): affected from 1.36.0 up to 1.36.4; no fix listed
- github.com/envoyproxy/envoy (Go): affected from 1.36.0 up to 1.36.4; no fix listed
- envoy (Bitnami): affected all versions; fixed in 1.34.13, 1.35.9, 1.36.5, 1.37.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26310/ (Markdown: https://insights.sbomify.com/CVE-2026-26310/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26310
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26310
- OSV: https://osv.dev/vulnerability/CVE-2026-26310

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26310/
Summaries are generated and may contain mistakes; the official description above is the record.
