CVE-2026-26311 Envoy HTTP: filter chain execution on reset streams causing UAF crash
Attackers can trigger a use-after-free crash in Envoy proxy by sending data on reset streams, causing denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-26311?
CVE-2026-26311 is a medium-severity use after free vulnerability in Envoyproxy Envoy, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Envoy is a high-performance edge/middle/service proxy. Prior to 1.37.1, 1.36.5, 1.35.8, and 1.34.13, a logic vulnerability in Envoy's HTTP connection manager (FilterManager) that allows for Zombie Stream Filter Execution. This issue creates a "Use-After-Free" (UAF) or state-corruption window where filter callbacks are invoked on an HTTP stream that has already been logically reset and cleaned up. The vulnerability resides in source/common/http/filter_manager.cc within the FilterManager::decodeData method. The ActiveStream object remains valid in memory during the deferred deletion window. If a DATA frame arrives on this stream immediately after the reset (e.g., in the same packet processing cycle), the HTTP/2 codec invokes ActiveStream::decodeData, which cascades to FilterManager::decodeData. FilterManager::decodeData fails to check the saw_downstream_reset_ flag. It iterates over the decoder_filters_ list and invokes decodeData() on filters that have already received onDestroy(). This vulnerability is fixed in 1.37.1, 1.36.5, 1.35.8, and 1.34.13.
Weakness: CWE-416
Which versions are affected by CVE-2026-26311?
9 open source packages ship an affected version, including github.com/envoyproxy/envoy and envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/envoyproxy/envoy Go | All versions | None |
github.com/envoyproxy/envoy Go | All versions | None |
github.com/envoyproxy/envoy Go | All versions to 1.34.12 | None |
github.com/envoyproxy/envoy Go | All versions to 1.34.12 | None |
github.com/envoyproxy/envoy Go | From 1.35.0 to 1.35.8 | None |
github.com/envoyproxy/envoy Go | From 1.35.0 to 1.35.8 | None |
3 more packages
github.com/envoyproxy/envoy Go | From 1.36.0 to 1.36.4 | None |
github.com/envoyproxy/envoy Go | From 1.36.0 to 1.36.4 | None |
envoy Bitnami | All versions | 1.34.13, 1.35.9, 1.36.5, 1.37.1 |
Products include Envoyproxy Envoy.
How do I fix CVE-2026-26311?
Upgrade to a fixed version.
Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.
Is CVE-2026-26311 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26311 exists.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2026-26311, GHSA-84xm-r438-86px.