# CVE-2026-26311: Envoy HTTP: filter chain execution on reset streams causing UAF crash

> Attackers can trigger a use-after-free crash in Envoy proxy by sending data on reset streams, causing denial of service.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 10 Mar 2026
- **Also known as:** BIT-envoy-2026-26311, GHSA-84xm-r438-86px

## What is CVE-2026-26311?

CVE-2026-26311 is a medium-severity use after free vulnerability in Envoyproxy Envoy, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy is a high-performance edge/middle/service proxy. Prior to 1.37.1, 1.36.5, 1.35.8, and 1.34.13, a logic vulnerability in Envoy's HTTP connection manager (FilterManager) that allows for Zombie Stream Filter Execution. This issue creates a "Use-After-Free" (UAF) or state-corruption window where filter callbacks are invoked on an HTTP stream that has already been logically reset and cleaned up. The vulnerability resides in source/common/http/filter_manager.cc within the FilterManager::decodeData method. The ActiveStream object remains valid in memory during the deferred deletion window. If a DATA frame arrives on this stream immediately after the reset (e.g., in the same packet processing cycle), the HTTP/2 codec invokes ActiveStream::decodeData, which cascades to FilterManager::decodeData. FilterManager::decodeData fails to check the saw_downstream_reset_ flag. It iterates over the decoder_filters_ list and invokes decodeData() on filters that have already received onDestroy(). This vulnerability is fixed in 1.37.1, 1.36.5, 1.35.8, and 1.34.13.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-26311?

9 open source packages ship an affected version, including github.com/envoyproxy/envoy and envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/envoyproxy/envoy` | Go | All versions | None |
| `github.com/envoyproxy/envoy` | Go | All versions | None |
| `github.com/envoyproxy/envoy` | Go | All versions to 1.34.12 | None |
| `github.com/envoyproxy/envoy` | Go | All versions to 1.34.12 | None |
| `github.com/envoyproxy/envoy` | Go | From 1.35.0 to 1.35.8 | None |
| `github.com/envoyproxy/envoy` | Go | From 1.35.0 to 1.35.8 | None |
| `github.com/envoyproxy/envoy` | Go | From 1.36.0 to 1.36.4 | None |
| `github.com/envoyproxy/envoy` | Go | From 1.36.0 to 1.36.4 | None |
| `envoy` | Bitnami | All versions | 1.34.13, 1.35.9, 1.36.5, 1.37.1 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2026-26311?

Upgrade to a fixed version.

## Is CVE-2026-26311 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26311 exists.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26311 and fix it if it is affected.

What it is: CVE-2026-26311 is a medium-severity use after free vulnerability in Envoyproxy Envoy, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26311 exists.

Affected packages and fixed versions:
- github.com/envoyproxy/envoy (Go): affected all versions; no fix listed
- github.com/envoyproxy/envoy (Go): affected all versions; no fix listed
- github.com/envoyproxy/envoy (Go): affected all versions up to 1.34.12; no fix listed
- github.com/envoyproxy/envoy (Go): affected all versions up to 1.34.12; no fix listed
- github.com/envoyproxy/envoy (Go): affected from 1.35.0 up to 1.35.8; no fix listed
- github.com/envoyproxy/envoy (Go): affected from 1.35.0 up to 1.35.8; no fix listed
- github.com/envoyproxy/envoy (Go): affected from 1.36.0 up to 1.36.4; no fix listed
- github.com/envoyproxy/envoy (Go): affected from 1.36.0 up to 1.36.4; no fix listed
- envoy (Bitnami): affected all versions; fixed in 1.34.13, 1.35.9, 1.36.5, 1.37.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26311/ (Markdown: https://insights.sbomify.com/CVE-2026-26311/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26311
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26311
- OSV: https://osv.dev/vulnerability/CVE-2026-26311

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26311/
Summaries are generated and may contain mistakes; the official description above is the record.
