# CVE-2026-26314: Go Ethereum affected by DoS via malicious p2p message

> Attackers can crash Go Ethereum nodes by sending specially crafted peer-to-peer messages, requiring an upgrade to patched versions.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** GHSA-2gjw-fg97-vg3r, GO-2026-4507

## What is CVE-2026-26314?

CVE-2026-26314 is a high-severity denial of service vulnerability in go-ethereum, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

go-ethereum (geth) is a golang execution layer implementation of the Ethereum protocol. Prior to version 1.16.9, a vulnerable node can be forced to shutdown/crash using a specially crafted message. The problem is resolved in the v1.16.9 and v1.17.0 releases of Geth.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-26314?

3 open source packages ship an affected version, including github.com/ethereum/go-ethereum. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ethereum/go-ethereum` | Go | All versions | 1.16.9 |
| `github.com/ethereum/go-ethereum` | Go | All versions | 1.16.9 |
| `github.com/ethereum/go-ethereum` | Go | All versions | 1.16.9 |

Products: Ethereum Go Ethereum.

## How do I fix CVE-2026-26314?

Upgrade github.com/ethereum/go-ethereum to 1.16.9 or later.

## Is CVE-2026-26314 being exploited?

There is no known exploitation of CVE-2026-26314 in the wild and no public exploit code.

## Other vulnerabilities in go-ethereum

- [CVE-2023-42319](https://insights.sbomify.com/CVE-2023-42319/): go-ethereum vulnerable to denial of service via crafted GraphQL query (high 7.5)
- [CVE-2023-40591](https://insights.sbomify.com/CVE-2023-40591/): Denial of service via malicious p2p message in go-ethereum (high 7.5)
- [CVE-2021-42219](https://insights.sbomify.com/CVE-2021-42219/): Denial of service in go-ethereum (high 7.5)
- [CVE-2022-23327](https://insights.sbomify.com/CVE-2022-23327/): Denial of Service in Go-Ethereum (high 7.5)
- [CVE-2022-23328](https://insights.sbomify.com/CVE-2022-23328/): Denial of Service in Go-Ethereum (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26314 and fix it if it is affected.

What it is: CVE-2026-26314 is a high-severity denial of service vulnerability in go-ethereum, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26314 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ethereum/go-ethereum (Go): affected all versions; fixed in 1.16.9
- github.com/ethereum/go-ethereum (Go): affected all versions; fixed in 1.16.9
- github.com/ethereum/go-ethereum (Go): affected all versions; fixed in 1.16.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26314/ (Markdown: https://insights.sbomify.com/CVE-2026-26314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26314
- OSV: https://osv.dev/vulnerability/CVE-2026-26314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26314/
Summaries are generated and may contain mistakes; the official description above is the record.
