# CVE-2026-26316: OpenClaw has BlueBubbles webhook auth bypass via loopback proxy trust

> Attackers can bypass authentication in the optional BlueBubbles plugin by spoofing loopback addresses, allowing unauthorized webhook access.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** GHSA-pchc-86f6-8758

## What is CVE-2026-26316?

CVE-2026-26316 is a high-severity authentication bypass vulnerability in Openclaw Openclaw, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenClaw is a personal AI assistant. Prior to 2026.2.13, the optional BlueBubbles iMessage channel plugin could accept webhook requests as authenticated based only on the TCP peer address being loopback (`127.0.0.1`, `::1`, `::ffff:127.0.0.1`) even when the configured webhook secret was missing or incorrect. This does not affect the default iMessage integration unless BlueBubbles is installed and enabled. Version 2026.2.13 contains a patch. Other mitigations include setting a non-empty BlueBubbles webhook password and avoiding deployments where a public-facing reverse proxy forwards to a loopback-bound Gateway without strong upstream authentication.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-26316?

4 open source packages ship an affected version, including @openclaw/bluebubbles and openclaw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openclaw/bluebubbles` | npm | All versions | 2026.2.13 |
| `@openclaw/bluebubbles` | npm | All versions | 2026.2.13 |
| `openclaw` | npm | All versions | 2026.2.13 |
| `openclaw` | npm | All versions | 2026.2.13 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-26316?

Upgrade @openclaw/bluebubbles to 2026.2.13 or later.

## Is CVE-2026-26316 being exploited?

There is no known exploitation of CVE-2026-26316 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26316 and fix it if it is affected.

What it is: CVE-2026-26316 is a high-severity authentication bypass vulnerability in Openclaw Openclaw, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26316 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openclaw/bluebubbles (npm): affected all versions; fixed in 2026.2.13
- @openclaw/bluebubbles (npm): affected all versions; fixed in 2026.2.13
- openclaw (npm): affected all versions; fixed in 2026.2.13
- openclaw (npm): affected all versions; fixed in 2026.2.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26316/ (Markdown: https://insights.sbomify.com/CVE-2026-26316/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26316
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26316
- OSV: https://osv.dev/vulnerability/CVE-2026-26316

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26316/
Summaries are generated and may contain mistakes; the official description above is the record.
