# CVE-2026-26317: OpenClaw affected by cross-site request forgery (CSRF) through loopback browser mutation endpoints

> A malicious website can trigger unauthorized state changes in OpenClaw's local browser control plane via CSRF, allowing attackers to manipulate tabs, storage, or browser status.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** GHSA-3fqr-4cg8-h96q

## What is CVE-2026-26317?

CVE-2026-26317 is a high-severity vulnerability in Openclaw Openclaw, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenClaw is a personal AI assistant. Prior to 2026.2.14, browser-facing localhost mutation routes accepted cross-origin browser requests without explicit Origin/Referer validation. Loopback binding reduces remote exposure but does not prevent browser-initiated requests from malicious origins. A malicious website can trigger unauthorized state changes against a victim's local OpenClaw browser control plane (for example opening tabs, starting/stopping the browser, mutating storage/cookies) if the browser control service is reachable on loopback in the victim's browser context. Starting in version 2026.2.14, mutating HTTP methods (POST/PUT/PATCH/DELETE) are rejected when the request indicates a non-loopback Origin/Referer (or `Sec-Fetch-Site: cross-site`). Other mitigations include enabling browser control auth (token/password) and avoid running with auth disabled.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-26317?

4 open source packages ship an affected version, including openclaw and clawdbot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | All versions | 2026.2.14 |
| `openclaw` | npm | All versions | 2026.2.14 |
| `clawdbot` | npm | All versions to 2026.1.24-3 | None |
| `clawdbot` | npm | All versions to 2026.1.24-3 | None |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-26317?

Upgrade openclaw to 2026.2.14 or later.

## Is CVE-2026-26317 being exploited?

There is no known exploitation of CVE-2026-26317 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26317 and fix it if it is affected.

What it is: CVE-2026-26317 is a high-severity vulnerability in Openclaw Openclaw, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-26317 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected all versions; fixed in 2026.2.14
- openclaw (npm): affected all versions; fixed in 2026.2.14
- clawdbot (npm): affected all versions up to 2026.1.24-3; no fix listed
- clawdbot (npm): affected all versions up to 2026.1.24-3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26317/ (Markdown: https://insights.sbomify.com/CVE-2026-26317/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26317
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26317
- OSV: https://osv.dev/vulnerability/CVE-2026-26317

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26317/
Summaries are generated and may contain mistakes; the official description above is the record.
