# CVE-2026-26319: OpenClaw has Missing Webhook Authentication in Telnyx Provider Allowing Unauthenticated Requests

> Attackers can forge Telnyx events by sending unsigned webhooks if the public key is unconfigured, bypassing authentication in the voice-call plugin.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** GHSA-4hg8-92x6-h2f3

## What is CVE-2026-26319?

CVE-2026-26319 is a high-severity missing authorization vulnerability in Openclaw Openclaw, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenClaw is a personal AI assistant. Versions 2026.2.13 and below allow the optional @openclaw/voice-call plugin Telnyx webhook handler to accept unsigned inbound webhook requests when telnyx.publicKey is not configured, enabling unauthenticated callers to forge Telnyx events. Telnyx webhooks are expected to be authenticated via Ed25519 signature verification. In affected versions, TelnyxProvider.verifyWebhook() could effectively fail open when no Telnyx public key was configured, allowing arbitrary HTTP POST requests to the voice-call webhook endpoint to be treated as legitimate Telnyx events. This only impacts deployments where the Voice Call plugin is installed, enabled, and the webhook endpoint is reachable from the attacker (for example, publicly exposed via a tunnel/proxy). The issue has been fixed in version 2026.2.14.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-26319?

2 open source packages ship an affected version, including openclaw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | All versions | 2026.2.14 |
| `openclaw` | npm | All versions | 2026.2.14 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-26319?

Upgrade openclaw to 2026.2.14 or later.

## Is CVE-2026-26319 being exploited?

There is no known exploitation of CVE-2026-26319 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26319 and fix it if it is affected.

What it is: CVE-2026-26319 is a high-severity missing authorization vulnerability in Openclaw Openclaw, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26319 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected all versions; fixed in 2026.2.14
- openclaw (npm): affected all versions; fixed in 2026.2.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26319/ (Markdown: https://insights.sbomify.com/CVE-2026-26319/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26319
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26319
- OSV: https://osv.dev/vulnerability/CVE-2026-26319

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26319/
Summaries are generated and may contain mistakes; the official description above is the record.
