# CVE-2026-26323: OpenClaw has a command injection in maintainer clawtributors updater

> Maintainers running a specific update script in a source checkout can execute arbitrary commands via malicious commit author emails.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** GHSA-m7x8-2w3w-pr42

## What is CVE-2026-26323?

CVE-2026-26323 is a high-severity command injection vulnerability in Openclaw Openclaw, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenClaw is a personal AI assistant. Versions 2026.1.8 through 2026.2.13 have a command injection in the maintainer/dev script `scripts/update-clawtributors.ts`. The issue affects contributors/maintainers (or CI) who run `bun scripts/update-clawtributors.ts` in a source checkout that contains a malicious commit author email (e.g. crafted `@users[.]noreply[.]github[.]com` values). Normal CLI usage is not affected (`npm i -g openclaw`): this script is not part of the shipped CLI and is not executed during routine operation. The script derived a GitHub login from `git log` author metadata and interpolated it into a shell command (via `execSync`). A malicious commit record could inject shell metacharacters and execute arbitrary commands when the script is run. Version 2026.2.14 contains a patch.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-26323?

2 open source packages ship an affected version, including openclaw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | From 2026.1.8 | 2026.2.14 |
| `openclaw` | npm | From 2026.1.8 | 2026.2.14 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-26323?

Upgrade openclaw to 2026.2.14 or later.

## Is CVE-2026-26323 being exploited?

There is no known exploitation of CVE-2026-26323 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26323 and fix it if it is affected.

What it is: CVE-2026-26323 is a high-severity command injection vulnerability in Openclaw Openclaw, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-26323 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected from 2026.1.8; fixed in 2026.2.14
- openclaw (npm): affected from 2026.1.8; fixed in 2026.2.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26323/ (Markdown: https://insights.sbomify.com/CVE-2026-26323/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26323
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26323
- OSV: https://osv.dev/vulnerability/CVE-2026-26323

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26323/
Summaries are generated and may contain mistakes; the official description above is the record.
