# CVE-2026-2635: MLflow Use of Default Password Authentication Bypass Vulnerability

> Remote attackers can bypass authentication using hard-coded default credentials in MLflow to execute arbitrary code as administrator.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-gq3w-7jj3-x7gr, PYSEC-2026-421

## What is CVE-2026-2635?

CVE-2026-2635 is a critical vulnerability in MLflow, published on 20 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MLflow Use of Default Password Authentication Bypass Vulnerability. This vulnerability allows remote attackers to bypass authentication on affected installations of MLflow. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the basic_auth.ini file. The file contains hard-coded default credentials. An attacker can leverage this vulnerability to bypass authentication and execute arbitrary code in the context of the administrator. Was ZDI-CAN-28256.

Weakness: CWE-798 (Use of Hard-coded Credentials), CWE-1393 (Use of Default Password)

## Which versions are affected by CVE-2026-2635?

3 open source packages ship an affected version, including mlflow.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | PyPI | All versions | 3.8.0rc0 |
| `mlflow` | PyPI | All versions | 3.8.0rc0 |
| `mlflow` | PyPI | All versions | 3.8.0rc0 |

## How do I fix CVE-2026-2635?

Upgrade mlflow to 3.8.0rc0 or later.

## Is CVE-2026-2635 being exploited?

There is no known exploitation of CVE-2026-2635 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2635 and fix it if it is affected.

What it is: CVE-2026-2635 is a critical vulnerability in MLflow, published on 20 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2635 in the wild and no public exploit code.

Affected packages and fixed versions:
- mlflow (PyPI): affected all versions; fixed in 3.8.0rc0
- mlflow (PyPI): affected all versions; fixed in 3.8.0rc0
- mlflow (PyPI): affected all versions; fixed in 3.8.0rc0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2635/ (Markdown: https://insights.sbomify.com/CVE-2026-2635/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2635
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2635
- OSV: https://osv.dev/vulnerability/CVE-2026-2635

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2635/
Summaries are generated and may contain mistakes; the official description above is the record.
