# CVE-2026-2651: Missing Authorization Validation in mlflow/mlflow

> Attackers can overwrite other users' artifacts in MLflow when artifact serving is enabled, potentially leading to model poisoning and code execution.

- **Severity:** Critical 9.0 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 May 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-mlflow-2026-2651, CLSA-2026-1787146516, CLSA-2026-1788334607, GHSA-8c7q-86fq-vvmh, PYSEC-2026-2220

## What is CVE-2026-2651?

CVE-2026-2651 is a critical missing authorization vulnerability in Lfprojects Mlflow, published on 25 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability in MLflow versions <=3.10.1.dev0 allows unauthorized access to multipart upload (MPU) endpoints when the `--serve-artifacts` mode is enabled. The authorization logic does not enforce resource-level permission checks for `/mlflow-artifacts/mpu/*` endpoints, enabling attackers to overwrite artifacts belonging to other users. This can lead to unauthorized cross-user writes, model supply chain poisoning, and arbitrary code execution when compromised models are loaded. The issue is resolved in version 3.10.0.

Weakness: CWE-1220 (Insufficient Granularity of Access Control), CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-2651?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 3.11.1 |
| `mlflow` | PyPI | All versions | 3.10.0 |
| `mlflow` | PyPI | All versions | 3.10.0 |
| `mlflow` | PyPI | All versions | 3.11.0rc0 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2026-2651?

Upgrade mlflow to a fixed version for your release line: 3.11.1, 3.10.0 or 3.11.0rc0.

## Is CVE-2026-2651 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2651 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2651 and fix it if it is affected.

What it is: CVE-2026-2651 is a critical missing authorization vulnerability in Lfprojects Mlflow, published on 25 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2651 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 3.11.1
- mlflow (PyPI): affected all versions; fixed in 3.10.0
- mlflow (PyPI): affected all versions; fixed in 3.10.0
- mlflow (PyPI): affected all versions; fixed in 3.11.0rc0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2651/ (Markdown: https://insights.sbomify.com/CVE-2026-2651/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2651
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2651
- OSV: https://osv.dev/vulnerability/CVE-2026-2651

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2651/
Summaries are generated and may contain mistakes; the official description above is the record.
