# CVE-2026-2652: Authentication Bypass in mlflow/mlflow

> Unauthenticated attackers can access job and trace APIs in MLflow when using uvicorn with basic auth, allowing job submission and data injection.

- **Severity:** High 8.6 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2026
- **Updated:** 15 May 2026
- **Also known as:** BIT-mlflow-2026-2652, GHSA-75cm-x2w3-8mgf, PYSEC-2026-2221

## What is CVE-2026-2652?

CVE-2026-2652 is a high-severity authentication bypass vulnerability in Lfprojects Mlflow, published on 15 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in mlflow/mlflow versions 3.9.0 and earlier allows unauthenticated access to certain FastAPI routes when the server is started with authentication enabled (`--app-name basic-auth`) and served via uvicorn (ASGI). The FastAPI permission middleware only enforces authentication on `/gateway/` routes, leaving other routes such as the Job API (`/ajax-api/3.0/jobs/*`) and the OpenTelemetry trace ingestion API (`/v1/traces`) unprotected. This allows unauthenticated remote attackers to submit jobs, read job results, cancel running jobs, and inject arbitrary trace data into experiments. The issue arises from an architectural mismatch between Flask and FastAPI authentication mechanisms, where the `_find_fastapi_validator()` function fails to handle non-`/gateway/` paths, resulting in a complete authentication bypass. This vulnerability is fixed in version 3.10.0.

Weakness: CWE-305 (Authentication Bypass by Primary Weakness)

## Which versions are affected by CVE-2026-2652?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 3.10.0 |
| `mlflow` | PyPI | All versions | 3.10.0 |
| `mlflow` | PyPI | All versions | 3.11.0 |
| `mlflow` | PyPI | All versions | 3.11.0 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2026-2652?

Upgrade mlflow to a fixed version for your release line: 3.10.0 or 3.11.0.

## Is CVE-2026-2652 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2652 exists.

Public exploit code:

- MLflow < 3.10.0 - Authentication Bypass on FastAPI Routes (nuclei): http/cves/2026/CVE-2026-2652.yaml

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2652 and fix it if it is affected.

What it is: CVE-2026-2652 is a high-severity authentication bypass vulnerability in Lfprojects Mlflow, published on 15 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2652 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 3.10.0
- mlflow (PyPI): affected all versions; fixed in 3.10.0
- mlflow (PyPI): affected all versions; fixed in 3.11.0
- mlflow (PyPI): affected all versions; fixed in 3.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2652/ (Markdown: https://insights.sbomify.com/CVE-2026-2652/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2652
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2652
- OSV: https://osv.dev/vulnerability/CVE-2026-2652

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2652/
Summaries are generated and may contain mistakes; the official description above is the record.
