# CVE-2026-2653: admesh normals.c stl_check_normal_vector heap-based overflow

> A heap-based buffer overflow in admesh allows local attackers to execute arbitrary code or cause denial of service via crafted STL files.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2026
- **Updated:** 23 Feb 2026
- **Also known as:** DEBIAN-CVE-2026-2653, GHSA-vcj6-96x2-26j3, PYSEC-2026-5, UBUNTU-CVE-2026-2653

## What is CVE-2026-2653?

CVE-2026-2653 is a medium-severity memory corruption vulnerability in admesh, published on 18 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A security flaw has been discovered in admesh up to 0.98.5. This issue affects the function stl_check_normal_vector of the file src/normals.c. Performing a manipulation results in heap-based buffer overflow. The attack must be initiated from a local position. The exploit has been released to the public and may be used for attacks. It looks like this product is not really maintained anymore.

Weakness: CWE-122 (Heap-based Buffer Overflow), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2026-2653?

1 open source package ship an affected version, including admesh. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `admesh` | PyPI | All versions | 0.98.6 |

Products: Admesh Project Admesh.

## How do I fix CVE-2026-2653?

Upgrade admesh to 0.98.6 or later.

## Is CVE-2026-2653 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2653 exists.

## Other vulnerabilities in admesh

- [CVE-2018-25033](https://insights.sbomify.com/CVE-2018-25033/): Out-of-bounds read in admesh (high 8.1)
- [CVE-2022-38072](https://insights.sbomify.com/CVE-2022-38072/): ADMesh improper array index validation (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2653 and fix it if it is affected.

What it is: CVE-2026-2653 is a medium-severity memory corruption vulnerability in admesh, published on 18 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2653 exists.

Affected packages and fixed versions:
- admesh (PyPI): affected all versions; fixed in 0.98.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2653/ (Markdown: https://insights.sbomify.com/CVE-2026-2653/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2653
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2653
- OSV: https://osv.dev/vulnerability/CVE-2026-2653

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2653/
Summaries are generated and may contain mistakes; the official description above is the record.
