# CVE-2026-2664: Out of bounds read vulnerability in grpcfuse kernel module

> A local attacker can read out-of-bounds memory in the grpcfuse kernel module via /proc/docker entries, potentially exposing sensitive data.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-x7c5-fjpp-2mcc

## What is CVE-2026-2664?

CVE-2026-2664 is a medium-severity vulnerability in Docker Desktop, published on 24 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An out of bounds read vulnerability in the grpcfuse kernel module present in the Linux VM in Docker Desktop for Windows, Linux and macOS up to version 4.61.0 could allow a local attacker to cause an unspecified impact by writing to /proc/docker entries. The issue has been fixed in Docker Desktop 4.62.0 .

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-2664?

It affects 1 product.


Products: Docker Desktop.

## How do I fix CVE-2026-2664?

No fix has been published for CVE-2026-2664 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-2664 being exploited?

There is no known exploitation of CVE-2026-2664 in the wild and no public exploit code.

## Other vulnerabilities in Docker Desktop

- [CVE-2024-8695](https://insights.sbomify.com/CVE-2024-8695/): Code injection in Docker Desktop (critical 9.0)
- [CVE-2024-8696](https://insights.sbomify.com/CVE-2024-8696/): Code injection in Docker Desktop (high 8.9)
- [CVE-2022-37326](https://insights.sbomify.com/CVE-2022-37326/): Path traversal in n/a (high 7.8)
- [CVE-2021-37841](https://insights.sbomify.com/CVE-2021-37841/): Missing authorization in n/a (high 7.8)
- [CVE-2025-3224](https://insights.sbomify.com/CVE-2025-3224/): Elevation of Privilege in Docker Desktop for Windows during Upgrade due to Insecure Directory Deletion (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2664 and fix it if it is affected.

What it is: CVE-2026-2664 is a medium-severity vulnerability in Docker Desktop, published on 24 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2664 in the wild and no public exploit code.

Affected product: Docker Desktop. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2664/ (Markdown: https://insights.sbomify.com/CVE-2026-2664/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2664
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2664
- OSV: https://osv.dev/vulnerability/CVE-2026-2664

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2664/
Summaries are generated and may contain mistakes; the official description above is the record.
