# CVE-2026-26717: OpenFUN Richie Observable Timing Discrepancy in its sync_course_run_from_request function

> Remote attackers can bypass authentication in OpenFUN Richie LMS by exploiting a timing side-channel in HMAC signature verification to forge valid signatures.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-xjhr-fm27-4hmx, PYSEC-2026-3052

## What is CVE-2026-26717?

CVE-2026-26717 is a medium-severity authentication bypass vulnerability in n/a, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue in OpenFUN Richie (LMS) in src/richie/apps/courses/api.py. The application used the non-constant time == operator for HMAC signature verification in the sync_course_run_from_request function. This allows remote attackers to forge valid signatures and bypass authentication by measuring response time discrepancies

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2026-26717?

3 open source packages ship an affected version, including richie.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `richie` | PyPI | All versions | 3.3.0 |
| `richie` | PyPI | All versions | 3.3.0 |
| `richie` | PyPI | All versions | 3.3.0 |

## How do I fix CVE-2026-26717?

Upgrade richie to 3.3.0 or later.

## Is CVE-2026-26717 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26717 exists.

Public exploit code:

- I discovered a Timing Attack vulnerability in the Richie LMS, developed by France Université Numérique (OpenFUN), and it was assigned the ID CVE-2026-26717 by MITRE. (github_poc): https://github.com/Rickidevs/CVE-2026-26717

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26717 and fix it if it is affected.

What it is: CVE-2026-26717 is a medium-severity authentication bypass vulnerability in n/a, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26717 exists.

Affected packages and fixed versions:
- richie (PyPI): affected all versions; fixed in 3.3.0
- richie (PyPI): affected all versions; fixed in 3.3.0
- richie (PyPI): affected all versions; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26717/ (Markdown: https://insights.sbomify.com/CVE-2026-26717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26717
- OSV: https://osv.dev/vulnerability/CVE-2026-26717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26717/
Summaries are generated and may contain mistakes; the official description above is the record.
