# CVE-2026-26861: CleverTap Web SDK is vulnerable to DOM-based XSS via handleCustomHtmlPreviewPostMessageEvent function

> An attacker can execute arbitrary JavaScript in the context of users interacting with the CleverTap Web SDK due to insufficient origin validation in postMessage handling.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Feb 2026
- **Updated:** 27 Feb 2026
- **Also known as:** GHSA-j5mf-6rh3-rhgg

## What is CVE-2026-26861?

CVE-2026-26861 is a high-severity cross-site scripting vulnerability in n/a, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CleverTap Web SDK version 1.15.2 and earlier is vulnerable to Cross-Site Scripting (XSS) via window.postMessage. The handleCustomHtmlPreviewPostMessageEvent function in src/util/campaignRender/nativeDisplay.js performs insufficient origin validation using the includes() method, which can be bypassed by an attacker using a subdomain

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-26861?

2 open source packages ship an affected version, including clevertap-web-sdk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `clevertap-web-sdk` | npm | All versions | 1.15.3 |
| `clevertap-web-sdk` | npm | All versions | 1.15.3 |

Products: Clevertap Clevertap Web Sdk.

## How do I fix CVE-2026-26861?

Upgrade clevertap-web-sdk to 1.15.3 or later.

## Is CVE-2026-26861 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26861 exists.

## Other vulnerabilities in n/a

- [CVE-2026-26862](https://insights.sbomify.com/CVE-2026-26862/): CleverTap Web SDK is vulnerable to DOM-based Cross-Site Scripting (XSS) via window.postMessage (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26861 and fix it if it is affected.

What it is: CVE-2026-26861 is a high-severity cross-site scripting vulnerability in n/a, published on 27 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26861 exists.

Affected packages and fixed versions:
- clevertap-web-sdk (npm): affected all versions; fixed in 1.15.3
- clevertap-web-sdk (npm): affected all versions; fixed in 1.15.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26861/ (Markdown: https://insights.sbomify.com/CVE-2026-26861/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26861
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26861
- OSV: https://osv.dev/vulnerability/CVE-2026-26861

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26861/
Summaries are generated and may contain mistakes; the official description above is the record.
