# CVE-2026-26938: Server-side request forgery in Kibana

> Authenticated users with workflow execution privileges can exploit template injection to read server files and perform SSRF.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2026
- **Updated:** 27 Feb 2026
- **Also known as:** BIT-elk-2026-26938, BIT-kibana-2026-26938, GHSA-9674-77c9-4xpr, MINI-32pp-h569-86r8

## What is CVE-2026-26938?

CVE-2026-26938 is a high-severity server-side request forgery vulnerability in Elastic Kibana, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) exists in Workflows in Kibana which could allow an attacker to read arbitrary files from the Kibana server filesystem, and perform Server-Side Request Forgery (SSRF) via Code Injection (CAPEC-242). This requires an authenticated user who has the workflowsManagement:executeWorkflow privilege.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-26938?

2 open source packages ship an affected version, including kibana and elk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kibana` | Bitnami | From 9.3.0 | 9.3.1 |
| `elk` | Bitnami | From 9.3.0 | 9.3.1 |

Products: Elastic Kibana.

## How do I fix CVE-2026-26938?

Upgrade kibana to 9.3.1 or later.

## Is CVE-2026-26938 being exploited?

There is no known exploitation of CVE-2026-26938 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Kibana

- [CVE-2019-7609](https://insights.sbomify.com/CVE-2019-7609/): Kibana Arbitrary Code Execution (critical 9.8, exploited in the wild)
- [CVE-2025-25015](https://insights.sbomify.com/CVE-2025-25015/): Kibana arbitrary code execution via prototype pollution (critical 9.9)
- [CVE-2024-37288](https://insights.sbomify.com/CVE-2024-37288/): Deserialization in Kibana (critical 9.9)
- [CVE-2023-31415](https://insights.sbomify.com/CVE-2023-31415/): Code injection in Kibana (critical 9.9)
- [CVE-2018-17245](https://insights.sbomify.com/CVE-2018-17245/): Information disclosure in Kibana (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26938 and fix it if it is affected.

What it is: CVE-2026-26938 is a high-severity server-side request forgery vulnerability in Elastic Kibana, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26938 in the wild and no public exploit code.

Affected packages and fixed versions:
- kibana (Bitnami): affected from 9.3.0; fixed in 9.3.1
- elk (Bitnami): affected from 9.3.0; fixed in 9.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26938/ (Markdown: https://insights.sbomify.com/CVE-2026-26938/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26938
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26938
- OSV: https://osv.dev/vulnerability/CVE-2026-26938

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26938/
Summaries are generated and may contain mistakes; the official description above is the record.
