# CVE-2026-26952: Pi-hole Web Interface has Stored HTML Injection via Local DNS Records (CNAME/Hosts) in data-tag Attribute

> Authenticated administrators can inject HTML into DNS records, bypassing CSP restrictions to potentially alter page rendering or behavior.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** GHSA-6xp4-jw73-f4qp

## What is CVE-2026-26952?

CVE-2026-26952 is a medium-severity cross-site scripting vulnerability in pi-hole web, published on 19 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pi-hole Admin Interface is a web interface for managing Pi-hole, a network-level ad and internet tracker blocking application. Versions 6.4 and below are vulnerable to stored HTML injection through the local DNS records configuration page, which allows an authenticated administrator to inject code that is stored in the Pi-hole configuration and rendered every time the DNS records table is viewed. The populateDataTable() function contains a data variable with the full DNS record value exactly as entered by the user and returned by the API. This value is inserted directly into the data-tag HTML attribute without any escaping or sanitization of special characters. When an attacker supplies a value containing double quotes ("), they can prematurely “close” the data-tag attribute and inject additional HTML attributes into the element. Since Pi-hole implements a Content Security Policy (CSP) that blocks inline JavaScript, the impact is limited. This issue has been fixed in version 6.4.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-20 (Improper Input Validation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-26952?

It affects 1 product.


Products: Pi-Hole Web Interface.

## How do I fix CVE-2026-26952?

Upgrade to a fixed version.

## Is CVE-2026-26952 being exploited?

There is no known exploitation of CVE-2026-26952 in the wild and no public exploit code.

## Other vulnerabilities in pi-hole web

- [CVE-2026-33765](https://insights.sbomify.com/CVE-2026-33765/): Pi-hole Web Interface has a Command Injection Vulnerability (high 8.9)
- [CVE-2023-23614](https://insights.sbomify.com/CVE-2023-23614/): Improper session handling of "Remember me for 7 days" functionality (high 8.8)
- [CVE-2025-59151](https://insights.sbomify.com/CVE-2025-59151/): Pi-hole Admin Interface vulnerable to HTTP response header injection via CRLF injection (high 8.2)
- [CVE-2021-3706](https://insights.sbomify.com/CVE-2021-3706/): Sensitive Cookie Without 'HttpOnly' Flag in pi-hole/adminlte (high 7.4)
- [CVE-2021-41175](https://insights.sbomify.com/CVE-2021-41175/): Stored XSS in Client Groups Management (Authenticated) (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26952 and fix it if it is affected.

What it is: CVE-2026-26952 is a medium-severity cross-site scripting vulnerability in pi-hole web, published on 19 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26952 in the wild and no public exploit code.

Affected product: pi-hole web. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26952/ (Markdown: https://insights.sbomify.com/CVE-2026-26952/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26952
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26952
- OSV: https://osv.dev/vulnerability/CVE-2026-26952

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26952/
Summaries are generated and may contain mistakes; the official description above is the record.
