# CVE-2026-26958: filippo.io/edwards25519 MultiScalarMult produces invalid results or undefined behavior if receiver is not the identity

> The MultiScalarMult function in the edwards25519 Go library returns invalid results or undefined behavior when the receiver is not the identity point.

- **Severity:** Low 1.7 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** AZL-78123, AZL-78216, CLEANSTART-2026-OU79790, CLEANSTART-2026-RM10286, CLEANSTART-2026-SU88556, CLEANSTART-2026-UP96283, CLEANSTART-2026-XD72543, DEBIAN-CVE-2026-26958, GHSA-fw7p-63qq-7hpr, GO-2026-4503, MINI-2c9j-rxr6-pc72, MINI-2m86-2fxh-cpcx, MINI-2mm4-9hx6-m265, MINI-332h-mv92-wccr, MINI-3c73-9xc7-rf4w, MINI-3q26-jr7j-7h78, MINI-4234-h4xx-8879, MINI-4frr-67qh-758j, MINI-4jp9-j5x4-hj5r, MINI-529m-xrvc-57g6, MINI-53rv-94wg-hw2g, MINI-5j5f-mv3v-76mh, MINI-5mj3-jmcw-fvvc, MINI-5qmm-2hp8-cmcx, MINI-6224-3586-x44m, MINI-6wm9-fxmp-pgcq, MINI-7fvq-p6xr-4fvr, MINI-8c9h-c32h-fgp6, MINI-8hq7-8498-hqxv, MINI-8v4h-v9g7-87wv, MINI-8w3m-868c-g6h9, MINI-9gmx-96x6-4c3g, MINI-9mr9-4r84-f2xx, MINI-9q8r-3w6p-x75q, MINI-9rwr-h4cp-fxg9, MINI-ch5m-rv4p-r3h2, MINI-chrj-667c-26q9, MINI-cv37-7f98-r2xr, MINI-f626-54xx-wmmx, MINI-g4v5-226r-px9p, MINI-gh43-4q36-pp82, MINI-gh5q-p5c8-22rp, MINI-gqj9-r2h8-gccg, MINI-gx35-q254-4mjp, MINI-h798-jqh7-3g4p, MINI-h9mv-gpjm-3w8g, MINI-j7cq-gjjw-p7pw, MINI-m2q8-vgrg-5jwg, MINI-mj8w-ww6r-7c8q, MINI-mq6q-4xcr-vhwh, MINI-mr33-p69r-g3gq, MINI-p5hw-gxgr-6mjf, MINI-p9x9-49f2-2gv9, MINI-q2xv-8x6r-vx3r, MINI-q54j-7c7q-cpm9, MINI-q9m6-rccq-hpwq, MINI-qcc5-wrr2-ghgh, MINI-qcqx-jhf7-pf33, MINI-qjr4-7hqg-v5rx, MINI-qrc3-j5h9-8548, MINI-qwc3-whgw-rr55, MINI-qxgm-jr27-c7rp, MINI-r3f3-pcjj-8jxp, MINI-r963-r3rh-fm65, MINI-rfv5-rmfw-93rf, MINI-rx6f-mxp8-2vg4, MINI-v7h3-985v-3r77, MINI-w46q-w6qc-jr5g, MINI-wr7q-w566-jv35, MINI-wxq2-6fc7-5mr3, MINI-x2mm-qj22-9463, MINI-xfhw-hpr4-mff9, MINI-xq9j-x237-pr24, MINI-xrp7-h4g5-q7c4, MINI-xx53-5grx-f4p3, UBUNTU-CVE-2026-26958

## What is CVE-2026-26958?

CVE-2026-26958 is a low-severity vulnerability in FiloSottile filippo.io/edwards25519, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

filippo.io/edwards25519 is a Go library implementing the edwards25519 elliptic curve with APIs for building cryptographic primitives. In versions 1.1.0 and earlier, MultiScalarMult produces invalid results or undefined behavior if the receiver is not the identity point. If (*Point).MultiScalarMult is called on an initialized point that is not the identity point, it returns an incorrect result. If the method is called on an uninitialized point, the behavior is undefined. In particular, if the receiver is the zero value, MultiScalarMult returns an invalid point that compares Equal to every other point. Note that MultiScalarMult is a rarely used, advanced API. For example, users who depend on filippo.io/edwards25519 only through github.com/go-sql-driver/mysql are not affected. This issue has been fixed in version 1.1.1.

Weakness: CWE-665 (Improper Initialization)

## Which versions are affected by CVE-2026-26958?

3 open source packages ship an affected version, including filippo.io/edwards25519.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `filippo.io/edwards25519` | Go | All versions | 1.1.1 |
| `filippo.io/edwards25519` | Go | All versions | 1.1.1 |
| `filippo.io/edwards25519` | Go | All versions | 1.1.1 |

## How do I fix CVE-2026-26958?

Upgrade filippo.io/edwards25519 to 1.1.1 or later.

## Is CVE-2026-26958 being exploited?

There is no known exploitation of CVE-2026-26958 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26958 and fix it if it is affected.

What it is: CVE-2026-26958 is a low-severity vulnerability in FiloSottile filippo.io/edwards25519, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26958 in the wild and no public exploit code.

Affected packages and fixed versions:
- filippo.io/edwards25519 (Go): affected all versions; fixed in 1.1.1
- filippo.io/edwards25519 (Go): affected all versions; fixed in 1.1.1
- filippo.io/edwards25519 (Go): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26958/ (Markdown: https://insights.sbomify.com/CVE-2026-26958/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26958
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26958
- OSV: https://osv.dev/vulnerability/CVE-2026-26958

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26958/
Summaries are generated and may contain mistakes; the official description above is the record.
