# CVE-2026-26959: ADB Explorer Vulnerable to RCE via Insufficient Input Validation

> Attackers can execute arbitrary code by tricking users into launching ADB Explorer with a malicious configuration file pointing to a rogue binary.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 19 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** GHSA-gcgv-2jq7-74rp

## What is CVE-2026-26959?

CVE-2026-26959 is a high-severity code injection vulnerability in Alex4SSB ADB-Explorer, published on 19 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

ADB Explorer is a fluent UI for ADB on Windows. Versions 0.9.26020 and below fail to validate the integrity or authenticity of the ADB binary path specified in the ManualAdbPath setting before executing it, allowing arbitrary code execution with the privileges of the current user. An attacker can exploit this by crafting a malicious App.txt settings file that points ManualAdbPath to an arbitrary executable, then convincing a victim to launch the application with a command-line argument directing it to the malicious configuration directory. This vulnerability could be leveraged through social engineering tactics, such as distributing a shortcut bundled with a crafted settings file in an archive, resulting in RCE upon application startup. Thus issue has been fixed in version 0.9.26021.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2026-26959?


## How do I fix CVE-2026-26959?

No fix has been published for CVE-2026-26959 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-26959 being exploited?

There is no known exploitation of CVE-2026-26959 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26959 and fix it if it is affected.

What it is: CVE-2026-26959 is a high-severity code injection vulnerability in Alex4SSB ADB-Explorer, published on 19 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-26959 in the wild and no public exploit code.

Affected product: Alex4SSB ADB-Explorer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26959/ (Markdown: https://insights.sbomify.com/CVE-2026-26959/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26959
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26959
- OSV: https://osv.dev/vulnerability/CVE-2026-26959

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26959/
Summaries are generated and may contain mistakes; the official description above is the record.
