# CVE-2026-26960: node-tar has Arbitrary File Read/Write via Hardlink Target Escape Through Symlink Chain in Extraction

> Attackers can read or write arbitrary files by crafting a tar archive with hardlinks escaping the extraction directory via symlinks.


- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** CLEANSTART-2026-IA47367, CLEANSTART-2026-NN34341, DEBIAN-CVE-2026-26960, ECHO-73e4-b37f-d747, GHSA-83g3-92jg-28cx, MINI-2cmr-f274-j9g6, MINI-3fh2-fjfv-3c3v, MINI-3xgx-4g8r-hfhp, MINI-49jv-84xg-438c, MINI-587w-8hwq-g923, MINI-5pxv-cmwh-wxwm, MINI-72vf-gv8w-wpgm, MINI-7fm7-wfqh-mqq8, MINI-7vp2-q4cx-v885, MINI-8cww-cp47-m2rc, MINI-8jjm-6rcc-jrqc, MINI-8rpw-7377-68vg, MINI-c294-457x-5h47, MINI-f88r-m7m5-7mqj, MINI-h4xc-4crp-9jw3, MINI-h84h-chmg-9whc, MINI-hm3j-36wp-657f, MINI-hv8g-xx57-q6w9, MINI-j244-8hr5-rvrf, MINI-p734-h8hc-h9vq, MINI-pj9h-cr93-j57w, MINI-vx32-76vq-33wp, MINI-wp7x-cxm8-7433, MINI-x9hf-3mv2-675j, MINI-xvr4-fg8w-j873, ROOT-APP-NPM-CVE-2026-26960, UBUNTU-CVE-2026-26960

## What is CVE-2026-26960?

CVE-2026-26960 is a high-severity path traversal vulnerability in isaacs node-tar, published on 20 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

node-tar is a full-featured Tar for Node.js. When using default options in versions 7.5.7 and below, an attacker-controlled archive can create a hardlink inside the extraction directory that points to a file outside the extraction root, enabling arbitrary file read and write as the extracting user. Severity is high because the primitive bypasses path protections and turns archive extraction into a direct filesystem access primitive. This issue has been fixed in version 7.5.8.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-26960?

2 open source packages ship an affected version, including tar. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tar` | npm | All versions | 7.5.8 |
| `tar` | npm | All versions | 7.5.8 |

Products: Isaacs Tar.

## How do I fix CVE-2026-26960?

Upgrade tar to 7.5.8 or later.

## Is CVE-2026-26960 being exploited?

There is no known exploitation of CVE-2026-26960 in the wild and no public exploit code.

## Other vulnerabilities in isaacs node-tar

- [CVE-2026-59873](https://insights.sbomify.com/CVE-2026-59873/): node-tar: Decompression/parse DoS via unlimited input (critical 9.2)
- [CVE-2026-23950](https://insights.sbomify.com/CVE-2026-23950/): node-tar has Race Condition in Path Reservations via Unicode Ligature Collisions on macOS APFS (high 8.8)
- [CVE-2026-59874](https://insights.sbomify.com/CVE-2026-59874/): node-tar: Negative tar entry size causes infinite loop in archive replace (high 8.7)
- [CVE-2026-31802](https://insights.sbomify.com/CVE-2026-31802/): node-tar Symlink Path Traversal via Drive-Relative Linkpath (high 8.2)
- [CVE-2026-29786](https://insights.sbomify.com/CVE-2026-29786/): node-tar: Hardlink Path Traversal via Drive-Relative Linkpath (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26960 and fix it if it is affected.

What it is: CVE-2026-26960 is a high-severity path traversal vulnerability in isaacs node-tar, published on 20 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-26960 in the wild and no public exploit code.

Affected packages and fixed versions:
- tar (npm): affected all versions; fixed in 7.5.8
- tar (npm): affected all versions; fixed in 7.5.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26960/ (Markdown: https://insights.sbomify.com/CVE-2026-26960/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26960
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26960
- OSV: https://osv.dev/vulnerability/CVE-2026-26960

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26960/
Summaries are generated and may contain mistakes; the official description above is the record.
