# CVE-2026-26961: Rack: Multipart Boundary Parsing Ambiguity allowing WAF Bypass

> Attackers can bypass upstream WAFs by exploiting multipart boundary parsing ambiguity in Rack, requiring an intermediary that validates the first boundary.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 3 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-26961, GHSA-vgpv-f759-9wx3, MINI-24gf-58c3-jg97, MINI-3f2p-ff55-6569, MINI-3wf4-2qq6-23j2, MINI-46j5-45vf-53wx, MINI-4c68-pgfg-j66x, MINI-6c33-hqhc-r332, MINI-73c5-xwvr-p8vp, MINI-cv6g-hr6x-2xvg, MINI-gj4h-jpq5-3r2g, MINI-gprj-5p94-88hh, MINI-h4jq-vj2g-54f6, MINI-hhj6-7v7m-3m6q, MINI-hrrm-g558-mmcr, MINI-j45h-7vff-485g, MINI-j5vw-443x-qq85, MINI-jjx3-vjp2-4c5j, MINI-mc63-cm7p-w7qv, MINI-mjhg-3vmm-52jm, MINI-p3rr-wv5f-289q, MINI-pvph-6fwr-2g6f, MINI-q2mx-4vw7-x5wf, MINI-r465-3rhq-9vvr, MINI-vf9g-hfj3-gcg9, MINI-wf6r-vrh4-459j, UBUNTU-CVE-2026-26961

## What is CVE-2026-26961?

CVE-2026-26961 is a low-severity vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Multipart::Parser extracts the boundary parameter from multipart/form-data using a greedy regular expression. When a Content-Type header contains multiple boundary parameters, Rack selects the last one rather than the first. In deployments where an upstream proxy, WAF, or intermediary interprets the first boundary parameter, this mismatch can allow an attacker to smuggle multipart content past upstream inspection and have Rack parse a different body structure than the intermediary validated. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-26961?

6 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.2.23 |
| `rack` | RubyGems | All versions | 2.2.23 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |

Products: Rack Rack.

## How do I fix CVE-2026-26961?

Upgrade rack to a fixed version for your release line: 2.2.23, 3.1.21 or 3.2.6.

## Is CVE-2026-26961 being exploited?

There is no known exploitation of CVE-2026-26961 in the wild and no public exploit code.

## Other vulnerabilities in rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26961 and fix it if it is affected.

What it is: CVE-2026-26961 is a low-severity vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26961 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.2.23
- rack (RubyGems): affected all versions; fixed in 2.2.23
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26961/ (Markdown: https://insights.sbomify.com/CVE-2026-26961/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26961
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26961
- OSV: https://osv.dev/vulnerability/CVE-2026-26961

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26961/
Summaries are generated and may contain mistakes; the official description above is the record.
