# CVE-2026-26963: Cilium may not enforce host firewall policies when Native Routing, WireGuard and Node Encryption are enabled

> Attackers can bypass host firewall policies in Cilium when specific encryption and routing features are enabled, allowing unauthorized cross-node traffic.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** BIT-cilium-2026-26963, BIT-cilium-operator-2026-26963, BIT-hubble-relay-2026-26963, GHSA-5r23-prx4-mqg3, GO-2026-4522, MINI-92x6-8jwj-p6mq, MINI-gqcj-9cqm-67g4, MINI-hcf8-hc8p-qw98, MINI-rwxh-rp9m-c6mg, UBUNTU-CVE-2026-26963

## What is CVE-2026-26963?

CVE-2026-26963 is a medium-severity missing authorization vulnerability in cilium, published on 19 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Versions 1.18.0 through 1.18.5 will incorrectly permit traffic from Pods on other nodes when Native Routing, WireGuard and Node Encryption are enabled. This issue has been fixed in version 1.18.6.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-26963?

6 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | From 1.18.0 | 1.18.6 |
| `github.com/cilium/cilium` | Go | From 1.18.0 | 1.18.6 |
| `github.com/cilium/cilium` | Go | From 1.18.0 | 1.18.6 |
| `cilium` | Bitnami | From 1.18.0 | 1.18.6 |
| `cilium-operator` | Bitnami | From 1.18.0 | 1.18.6 |
| `hubble-relay` | Bitnami | From 1.18.0 | 1.18.6 |

Products: Cilium Cilium.

## How do I fix CVE-2026-26963?

Upgrade github.com/cilium/cilium to 1.18.6 or later.

## Is CVE-2026-26963 being exploited?

There is no known exploitation of CVE-2026-26963 in the wild and no public exploit code.

## Other vulnerabilities in cilium

- [CVE-2026-49445](https://insights.sbomify.com/CVE-2026-49445/): Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access (critical 9.2)
- [CVE-2022-29178](https://insights.sbomify.com/CVE-2022-29178/): Incorrect Default Permissions in Cilium (high 8.8)
- [CVE-2024-28860](https://insights.sbomify.com/CVE-2024-28860/): Insecure IPsec transport encryption in Cilium (high 8.0)
- [CVE-2026-41520](https://insights.sbomify.com/CVE-2026-41520/): Cillium exposes sensitive information included in the cilium-bugtool debug archive (high 7.9)
- [CVE-2024-37307](https://insights.sbomify.com/CVE-2024-37307/): Cilium leaks sensitive information in cilium-bugtool (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26963 and fix it if it is affected.

What it is: CVE-2026-26963 is a medium-severity missing authorization vulnerability in cilium, published on 19 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26963 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected from 1.18.0; fixed in 1.18.6
- github.com/cilium/cilium (Go): affected from 1.18.0; fixed in 1.18.6
- github.com/cilium/cilium (Go): affected from 1.18.0; fixed in 1.18.6
- cilium (Bitnami): affected from 1.18.0; fixed in 1.18.6
- cilium-operator (Bitnami): affected from 1.18.0; fixed in 1.18.6
- hubble-relay (Bitnami): affected from 1.18.0; fixed in 1.18.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26963/ (Markdown: https://insights.sbomify.com/CVE-2026-26963/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26963
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26963
- OSV: https://osv.dev/vulnerability/CVE-2026-26963

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26963/
Summaries are generated and may contain mistakes; the official description above is the record.
