CVE-2026-26974 Sylde has Improper Control of Generation of Code

High 7.6 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-26974?

CVE-2026-26974 is a high-severity vulnerability in Tygo-van-den-Hurk Slyde, published on 20 Feb 2026.

Official description

Slyde is a program that creates animated presentations from XML. In versions 0.0.4 and below, Node.js automatically imports **/*.plugin.{js,mjs} files including those from node_modules, so any malicious package with a .plugin.js file can execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages. This issue has been fixed in version 0.0.5. To workaround this issue, users can audit and restrict which packages are installed in node_modules.

Weakness: CWE-829

Which versions are affected by CVE-2026-26974?

2 open source packages ship an affected version, including @tygo-van-den-hurk/slyde. It affects 1 product.

PackageAffectedFixed in
@tygo-van-den-hurk/slyde npmAll versions0.0.5
@tygo-van-den-hurk/slyde npmAll versions0.0.5

Products include Slyde.js Slyde.

How do I fix CVE-2026-26974?

Upgrade @tygo-van-den-hurk/slyde to 0.0.5 or later.

Is CVE-2026-26974 being exploited?

There is no known exploitation of CVE-2026-26974 in the wild and no public exploit code.

Sources

Also known as GHSA-w7h5-55jg-cq2f.

Is CVE-2026-26974 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free