# CVE-2026-26974: Sylde has Improper Control of Generation of Code


- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** GHSA-w7h5-55jg-cq2f

## What is CVE-2026-26974?

CVE-2026-26974 is a high-severity vulnerability in Tygo-van-den-Hurk Slyde, published on 20 Feb 2026. 

### Official description

Slyde is a program that creates animated presentations from XML. In versions 0.0.4 and below, Node.js automatically imports **/*.plugin.{js,mjs} files including those from node_modules, so any malicious package with a .plugin.js file can execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages. This issue has been fixed in version 0.0.5. To workaround this issue, users can audit and restrict which packages are installed in node_modules.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2026-26974?

2 open source packages ship an affected version, including @tygo-van-den-hurk/slyde. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@tygo-van-den-hurk/slyde` | npm | All versions | 0.0.5 |
| `@tygo-van-den-hurk/slyde` | npm | All versions | 0.0.5 |

Products: Slyde.js Slyde.

## How do I fix CVE-2026-26974?

Upgrade @tygo-van-den-hurk/slyde to 0.0.5 or later.

## Is CVE-2026-26974 being exploited?

There is no known exploitation of CVE-2026-26974 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26974 and fix it if it is affected.

What it is: CVE-2026-26974 is a high-severity vulnerability in Tygo-van-den-Hurk Slyde, published on 20 Feb 2026. 
Exploitation: There is no known exploitation of CVE-2026-26974 in the wild and no public exploit code.

Affected packages and fixed versions:
- @tygo-van-den-hurk/slyde (npm): affected all versions; fixed in 0.0.5
- @tygo-van-den-hurk/slyde (npm): affected all versions; fixed in 0.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26974/ (Markdown: https://insights.sbomify.com/CVE-2026-26974/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26974
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26974
- OSV: https://osv.dev/vulnerability/CVE-2026-26974

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26974/
Summaries are generated and may contain mistakes; the official description above is the record.
