# CVE-2026-26978: Free PBX backup: Deserialization of Untrusted Data in admin/modules/backup/Models/BackupSplFileInfo.php

> Authenticated attackers can achieve remote code execution by restoring a malicious backup archive containing crafted serialized data.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 May 2026
- **Updated:** 20 May 2026
- **Also known as:** GHSA-5v7h-49gr-jcwr

## What is CVE-2026-26978?

CVE-2026-26978 is a high-severity unsafe deserialization vulnerability in FreePBX security-reporting, published on 18 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FreePBX is an open source IP PBX. In versions below 16.0.71 and 17.0.6, the backup module does not properly sanitize data during restore operations, potentially leading to compromise if the backup contains carefully crafted hostile data. During backup restore operations, FreePBX extracts selected files from a user-supplied tar archive. If a malicious file exists in the archive, it is read and passed directly to unserialize() without validation, class restrictions, or integrity checks. This issue allows Remote Code Execution during restoration of the backup as the web server user (typically asterisk or www-data). The attack does not require shell access, CLI access, or filesystem write permissions beyond the normal restore workflow. Authentication with a known username that has sufficient access permissions and/or write access to backup files is required. This issue has been fixed in versions 16.0.71 and 17.0.6.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-26978?


## How do I fix CVE-2026-26978?

No fix has been published for CVE-2026-26978 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-26978 being exploited?

There is no known exploitation of CVE-2026-26978 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26978 and fix it if it is affected.

What it is: CVE-2026-26978 is a high-severity unsafe deserialization vulnerability in FreePBX security-reporting, published on 18 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26978 in the wild and no public exploit code.

Affected product: FreePBX security-reporting. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26978/ (Markdown: https://insights.sbomify.com/CVE-2026-26978/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26978
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26978
- OSV: https://osv.dev/vulnerability/CVE-2026-26978

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26978/
Summaries are generated and may contain mistakes; the official description above is the record.
