CVE-2026-26981 OpenEXR has heap-buffer-overflow via signed integer underflow in ImfContextInit.cpp

Medium 6.5 Published Updated

A signed integer underflow in OpenEXR leads to a heap buffer overflow when parsing malformed files, potentially causing crashes or data exposure.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-26981?

CVE-2026-26981 is a medium-severity vulnerability in Openexr Openexr, published on 24 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. In versions 3.3.0 through 3.3.6 and 3.4.0 through 3.4.4, a heap-buffer-overflow (OOB read) occurs in the `istream_nonparallel_read` function in `ImfContextInit.cpp` when parsing a malformed EXR file through a memory-mapped `IStream`. A signed integer subtraction produces a negative value that is implicitly converted to `size_t`, resulting in a massive length being passed to `memcpy`. Versions 3.3.7 and 3.4.5 contain a patch.

Weakness: CWE-195

Which versions are affected by CVE-2026-26981?

5 open source packages ship an affected version, including openexr and OpenEXR. It affects 1 product.

PackageAffectedFixed in
openexr PyPIFrom 3.3.03.3.7, 3.4.5
openexr PyPIFrom 3.3.03.3.7
openexr PyPIFrom 3.4.03.4.5
OpenEXR PyPIFrom 3.3.03.3.7
OpenEXR PyPIFrom 3.4.03.4.5
Linux distribution packages (1)
openexr openSUSE:TumbleweedAll versions3.4.5-1.1

Products include Openexr Openexr.

How do I fix CVE-2026-26981?

Upgrade openexr to a fixed version for your release line: 3.3.7 or 3.4.5.

Is CVE-2026-26981 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26981 exists.

All Openexr Openexr vulnerabilities

Sources

Also known as GHSA-q6vj-wxvf-5m8c, JLSEC-2026-140, PYSEC-2026-2849, openSUSE-SU-2026:10272-1.

Is CVE-2026-26981 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free