CVE-2026-26987 LibreNMS affected by reflected XSS via email field

Medium 5.3 Published Updated

Attackers can execute arbitrary scripts in victim browsers via the email field, potentially leading to session hijacking or data theft.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-26987?

CVE-2026-26987 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 20 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Versions 25.12.0 and below are vulnerable to Reflected XSS attacks via email field. This issue has been fixed in version 26.2.0.

Weakness: CWE-79

Which versions are affected by CVE-2026-26987?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.

PackageAffectedFixed in
librenms/librenms PackagistAll versions26.2.0
librenms/librenms PackagistAll versions26.2.0

Products include Librenms Librenms.

How do I fix CVE-2026-26987?

Upgrade librenms/librenms to 26.2.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-26987 being exploited?

There is no known exploitation of CVE-2026-26987 in the wild and no public exploit code.

All Librenms Librenms vulnerabilities

Sources

Also known as GHSA-gqx7-99jw-6fpr.

Is CVE-2026-26987 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free