# CVE-2026-26988: LibreNMS: SQL Injection in ajax_table.php spreads through a covert data stream

> Attackers can inject SQL commands via the IPv6 address search parameter in LibreNMS, leading to unauthorized data access or database manipulation.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** GHSA-h3rv-q4rq-pqcv

## What is CVE-2026-26988?

CVE-2026-26988 is a critical SQL injection vulnerability in Librenms Librenms, published on 20 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Versions 25.12.0 and below contain an SQL Injection vulnerability in the ajax_table.php endpoint. The application fails to properly sanitize or parameterize user input when processing IPv6 address searches. Specifically, the address parameter is split into an address and a prefix, and the prefix portion is directly concatenated into the SQL query string without validation. This allows an attacker to inject arbitrary SQL commands, potentially leading to unauthorized data access or database manipulation. This issue has been fixed in version 26.2.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-26988?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 26.2.0 |
| `librenms/librenms` | Packagist | All versions | 26.2.0 |

Products: Librenms Librenms.

## How do I fix CVE-2026-26988?

Upgrade librenms/librenms to 26.2.0 or later.

## Is CVE-2026-26988 being exploited?

There is no known exploitation of CVE-2026-26988 in the wild and no public exploit code.

Public exploit code:

- https://github.com/mbanyamer/CVE-2026-26988-LibreNMS-SQLi (github_poc): https://github.com/mbanyamer/CVE-2026-26988-LibreNMS-SQLi

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26988 and fix it if it is affected.

What it is: CVE-2026-26988 is a critical SQL injection vulnerability in Librenms Librenms, published on 20 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-26988 in the wild and no public exploit code.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 26.2.0
- librenms/librenms (Packagist): affected all versions; fixed in 26.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26988/ (Markdown: https://insights.sbomify.com/CVE-2026-26988/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26988
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26988
- OSV: https://osv.dev/vulnerability/CVE-2026-26988

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26988/
Summaries are generated and may contain mistakes; the official description above is the record.
